If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Incredibly huge libsuite.so component

RESOLVED FIXED in seamonkey2.44

Status

SeaMonkey
Build Config
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: Dmitry Butskoy, Assigned: Dmitry Butskoy)

Tracking

SeaMonkey 2.39 Branch
seamonkey2.44

SeaMonkey Tracking Flags

(seamonkey2.44 fixed)

Details

(Whiteboard: [seamonkey-2.39-affected])

User Story

See also Bug 942031 - Don't link against the js engine when there's no need to

Attachments

(1 attachment)

507 bytes, patch
Philip Chee
: review+
neil@parkwaycc.co.uk
: feedback+
Details | Diff | Splinter Review
(Assignee)

Description

2 years ago
Created attachment 8711496 [details] [diff] [review]
moz.build-libsuite.patch

Sometime between 2.33 and 2.35, the installed file "components/libsuite.so" became too big. Instead of a size of ~80kb, now it is about 16 Megabytes !

The problem is due to extra library (static js) specified in "suite/build/moz.build" .

Attached patch resolves issue properly. Two weeks all works fine with me and other users.

It seems it was a typo or some test which was forgotten to remove...
On my system (SeaMonkey 2.43a1 for linux-x86_64 dated 2016-01-09), /usr/local/seamonkey/components/libsuite.so is about 130K. I don't call that "incredibly huge".

Which version of SeaMonkey are you using? 2.33 and 2.35 are already obsolete by months, and the problem may have been fixed since then.
(Assignee)

Comment 2

2 years ago
I use the current version of 2.39

Your version 2.43a1 seems to be "a nightly build" -- probably it is built by some different scheme? Another possibility is the using of "shared js" -- in such a case libsuite.so is linked against the shared js binary (instead of static as in my "default" case). Anyway such linking is not needed...
(In reply to Dmitry Butskoy from comment #2)
> I use the current version of 2.39
> 
> Your version 2.43a1 seems to be "a nightly build" -- probably it is built by
> some different scheme? Another possibility is the using of "shared js" -- in
> such a case libsuite.so is linked against the shared js binary (instead of
> static as in my "default" case). Anyway such linking is not needed...

Yes, I'm using nightly builds — of trunk, as a matter of fact, and as published at ftp.mozilla.org. (Well, current trunk is supposed to be 2.44a1 but AFAIK it hasn't been built yet.) I suppose you are downloading SeaMonkey from Mozilla (or from seamonkey-project.org) too? If you got it from your Linux distro, the build config might be different without Mozilla having anything to do with it, and in that case your distro's bug tracking system would be the right place to report this problem.

Setting tracking flags — and since the 2.39 tracking flag rolldowns are already hidden by now I'm using the Witeboard as fallback.
status-seamonkey2.43: --- → unaffected
Whiteboard: [seamonkey-2.39-affected]
Version: unspecified → SeaMonkey 2.39 Branch
(Assignee)

Comment 4

2 years ago
Could you please discover whether you 2.43a1 (ie. upcoming official seamonkey-2.40) are built with "--enable-shared-js" or not? What "ldd libsuite.so" shows?

I don't see any changes at hg.mozilla.org for the issue.

I maintain SeaMonkey for RedHat Fedora and RHEL, and currently we don't enable shared-js, hence the bug might take effect here and might not in your case.
(Assignee)

Updated

2 years ago
status-seamonkey2.43: unaffected → ---
(Assignee)

Comment 5

2 years ago
If it is not due to shared js, please, set 2.40 as unaffected. (I hope 43 in 2.43 is coming from base Mozilla version scheme (ie. Firefox 43), the actual SM-2.43 will appear sometime after Firefox-46 will be released).

Comment 6

2 years ago
Comment on attachment 8711496 [details] [diff] [review]
moz.build-libsuite.patch

>-# js needs to come after xul for now, because it is an archive and its content
>-# is discarded when it comes first.
>-USE_LIBS += [
>-    'js',
>-]
>-
Instead of removing it I think you should guard it with:
  if CONFIG['JS_SHARED_LIBRARY']:

See: http://mxr.mozilla.org/comm-central/source/mozilla/toolkit/components/places/tests/cpp/moz.build?rev=c646a88160d7&mark=11-14#10
(Assignee)

Comment 7

2 years ago
Well, but is the linking libsuite.so against "js" actually needed at all?
If it works properly "without js", then there are no unresolved symbols in libsuite.so, neither in static nor in shared mode...
(In reply to Dmitry Butskoy from comment #5)
> If it is not due to shared js, please, set 2.40 as unaffected. (I hope 43 in
> 2.43 is coming from base Mozilla version scheme (ie. Firefox 43), the actual
> SM-2.43 will appear sometime after Firefox-46 will be released).

No, SeaMonkey 2.43 uses Gecko 46. If SeaMonkey were building now, SeaMonkey 2.43a2 would be Aurora and 2.44a1 would be Trunk. However, the building stopped before the latest merge, and the latest aurora and trunk nightlies visible at ftp.mozilla.org are 2.42a2 ( ~ Firefox 45) and 2.43a1 ( ~ Firefox 46).

Comment 9

2 years ago
(In reply to Dmitry Butskoy from comment #7)
> Well, but is the linking libsuite.so against "js" actually needed at all?
> If it works properly "without js", then there are no unresolved symbols in
> libsuite.so, neither in static nor in shared mode...
It looks like Both Thunderbird and Firefox do not do this, so you are probably right.
Assignee: nobody → dmitry
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
OS: Linux → All

Updated

2 years ago
Attachment #8711496 - Flags: review?(iann_bugzilla)
Attachment #8711496 - Flags: feedback?(neil)
Comment on attachment 8711496 [details] [diff] [review]
moz.build-libsuite.patch

Well, last time I tried --enable-shared-js it didn't build anyway, so I guess we don't have to bother guarding it.
Attachment #8711496 - Flags: feedback?(neil) → feedback+

Updated

2 years ago
User Story: (updated)

Comment 11

2 years ago
Comment on attachment 8711496 [details] [diff] [review]
moz.build-libsuite.patch

I built SeaMonkey on Windows. Looks like nothing is broken r=me
Attachment #8711496 - Flags: review?(iann_bugzilla) → review+

Comment 12

2 years ago
http://hg.mozilla.org/comm-central/rev/8c08b200cfbd
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-seamonkey2.44: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.44
You need to log in before you can comment on or make changes to this bug.