Closed Bug 1242293 Opened 4 years ago Closed 4 years ago

Debug builds crash on startup: Assertion failure: mInUpdate (Ending update while not in update), at widget/cocoa/nsChildView.mm:2965

Categories

(Thunderbird :: General, defect, critical)

x86_64
macOS
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 47.0

People

(Reporter: sshagarwal, Assigned: mattwoodrow)

References

Details

(Keywords: crash, regression)

Attachments

(1 file)

Hi,

TB is crashing, randomly on me with the following content:

Assertion failure: mInUpdate (Ending update while not in update), at /Users/username/comm-central/mozilla/widget/cocoa/nsChildView.mm:2965
#01: (anonymous namespace)::RectTextureImage::EndUpdate(bool)[/Users/username/comm-central/thunderbird-binary/dist/DailyDebug.app/Contents/MacOS/XUL +0x481b01b]
#02: nsChildView::EndRemoteDrawing()[/Users/username/comm-central/thunderbird-binary/dist/DailyDebug.app/Contents/MacOS/XUL +0x481afa2]
#03: nsIWidget::EndRemoteDrawingInRegion(mozilla::gfx::DrawTarget*, mozilla::gfx::IntRegionTyped<mozilla::LayoutDevicePixel>&)[/Users/username/comm-central/thunderbird-binary/dist/DailyDebug.app/Contents/MacOS/XUL +0x47b47b4]
#04: mozilla::layers::BasicCompositor::BeginFrame(mozilla::gfx::IntRegionTyped<mozilla::gfx::UnknownUnits> const&, mozilla::gfx::RectTyped<mozilla::gfx::UnknownUnits, float> const*, mozilla::gfx::RectTyped<mozilla::gfx::UnknownUnits, float> const&, mozilla::gf[/Users/username/comm-central/thunderbird-binary/dist/DailyDebug.app/Contents/MacOS/XUL +0x1f81384]
#05: mozilla::layers::LayerManagerComposite::Render(mozilla::gfx::IntRegionTyped<mozilla::gfx::UnknownUnits> const&)[/Users/username/comm-central/thunderbird-binary/dist/DailyDebug.app/Contents/MacOS/XUL +0x1fe55b4]
#06: mozilla::layers::LayerManagerComposite::UpdateAndRender()[/Users/username/comm-central/thunderbird-binary/dist/DailyDebug.app/Contents/MacOS/XUL +0x1fe4c67]
#07: mozilla::layers::LayerManagerComposite::EndTransaction(mozilla::TimeStamp const&, mozilla::layers::LayerManager::EndTransactionFlags)[/Users/username/comm-central/thunderbird-binary/dist/DailyDebug.app/Contents/MacOS/XUL +0x1fe47bd]
#08: mozilla::layers::CompositorParent::CompositeToTarget(mozilla::gfx::DrawTarget*, mozilla::gfx::IntRectTyped<mozilla::gfx::UnknownUnits> const*)[/Users/username/comm-central/thunderbird-binary/dist/DailyDebug.app/Contents/MacOS/XUL +0x202634e]
#09: mozilla::layers::CompositorVsyncScheduler::ComposeToTarget(mozilla::gfx::DrawTarget*, mozilla::gfx::IntRectTyped<mozilla::gfx::UnknownUnits> const*)[/Users/username/comm-central/thunderbird-binary/dist/DailyDebug.app/Contents/MacOS/XUL +0x2025b24]
#10: mozilla::layers::CompositorVsyncScheduler::ForceComposeToTarget(mozilla::gfx::DrawTarget*, mozilla::gfx::IntRectTyped<mozilla::gfx::UnknownUnits> const*)[/Users/username/comm-central/thunderbird-binary/dist/DailyDebug.app/Contents/MacOS/XUL +0x2025bfa]
#11: mozilla::layers::CompositorParent::ForceComposeToTarget(mozilla::gfx::DrawTarget*, mozilla::gfx::IntRectTyped<mozilla::gfx::UnknownUnits> const*)[/Users/username/comm-central/thunderbird-binary/dist/DailyDebug.app/Contents/MacOS/XUL +0x20278de]
#12: mozilla::layers::CompositorParent::RecvFlushRendering()[/Users/username/comm-central/thunderbird-binary/dist/DailyDebug.app/Contents/MacOS/XUL +0x2027aef]
#13: mozilla::layers::PCompositorParent::OnMessageReceived(IPC::Message const&, IPC::Message*&)[/Users/username/comm-central/thunderbird-binary/dist/DailyDebug.app/Contents/MacOS/XUL +0x1655919]
#14: mozilla::ipc::MessageChannel::DispatchSyncMessage(IPC::Message const&, IPC::Message*&)[/Users/username/comm-central/thunderbird-binary/dist/DailyDebug.app/Contents/MacOS/XUL +0xf97728]
#15: mozilla::ipc::MessageChannel::DispatchMessage(IPC::Message const&)[/Users/username/comm-central/thunderbird-binary/dist/DailyDebug.app/Contents/MacOS/XUL +0xf96cd3]
#16: mozilla::ipc::MessageChannel::OnMaybeDequeueOne()[/Users/username/comm-central/thunderbird-binary/dist/DailyDebug.app/Contents/MacOS/XUL +0xf91e8e]
#17: void details::CallMethod<mozilla::ipc::MessageChannel, bool (mozilla::ipc::MessageChannel::*)()>(mozilla::IndexSequence<>, mozilla::ipc::MessageChannel*, bool (mozilla::ipc::MessageChannel::*)(), mozilla::Tuple<>&)[/Users/username/comm-central/thunderbird-binary/dist/DailyDebug.app/Contents/MacOS/XUL +0xfb82c3]
#18: void DispatchTupleToMethod<mozilla::ipc::MessageChannel, bool (mozilla::ipc::MessageChannel::*)()>(mozilla::ipc::MessageChannel*, bool (mozilla::ipc::MessageChannel::*)(), mozilla::Tuple<>&)[/Users/username/comm-central/thunderbird-binary/dist/DailyDebug.app/Contents/MacOS/XUL +0xfb8235]
#19: RunnableMethod<mozilla::ipc::MessageChannel, bool (mozilla::ipc::MessageChannel::*)(), mozilla::Tuple<> >::Run()[/Users/username/comm-central/thunderbird-binary/dist/DailyDebug.app/Contents/MacOS/XUL +0xfb811e]
#20: mozilla::ipc::MessageChannel::RefCountedTask::Run()[/Users/username/comm-central/thunderbird-binary/dist/DailyDebug.app/Contents/MacOS/XUL +0xfb4978]
#21: mozilla::ipc::MessageChannel::DequeueTask::Run()[/Users/username/comm-central/thunderbird-binary/dist/DailyDebug.app/Contents/MacOS/XUL +0xfb47c4]
#22: MessageLoop::RunTask(Task*)[/Users/username/comm-central/thunderbird-binary/dist/DailyDebug.app/Contents/MacOS/XUL +0xec60c0]
#23: MessageLoop::DeferOrRunPendingTask(MessageLoop::PendingTask const&)[/Users/username/comm-central/thunderbird-binary/dist/DailyDebug.app/Contents/MacOS/XUL +0xec662f]
#24: MessageLoop::DoWork()[/Users/username/comm-central/thunderbird-binary/dist/DailyDebug.app/Contents/MacOS/XUL +0xec6854]
#25: base::MessagePumpDefault::Run(base::MessagePump::Delegate*)[/Users/username/comm-central/thunderbird-binary/dist/DailyDebug.app/Contents/MacOS/XUL +0xec74a7]
#26: MessageLoop::RunInternal()[/Users/username/comm-central/thunderbird-binary/dist/DailyDebug.app/Contents/MacOS/XUL +0xec5fa5]
#27: MessageLoop::RunHandler()[/Users/username/comm-central/thunderbird-binary/dist/DailyDebug.app/Contents/MacOS/XUL +0xec5eb5]
#28: MessageLoop::Run()[/Users/username/comm-central/thunderbird-binary/dist/DailyDebug.app/Contents/MacOS/XUL +0xec5e5d]
#29: base::Thread::ThreadMain()[/Users/username/comm-central/thunderbird-binary/dist/DailyDebug.app/Contents/MacOS/XUL +0xeeae26]
#30: ThreadFunc(void*)[/Users/username/comm-central/thunderbird-binary/dist/DailyDebug.app/Contents/MacOS/XUL +0xeeaf1e]
#31: _pthread_body[/usr/lib/system/libsystem_pthread.dylib +0x405a]
#32: _pthread_body[/usr/lib/system/libsystem_pthread.dylib +0x3fd7]

It sometimes even crashes at the profile selection dialog box. So, I am assuming it has nothing to do with the profile 'coz I can't change it anyway.
Interesting, could this be a local reproduction of Bug 1240787?
are these regressions?
Blocks: 1240787
Hi Nicholas, I see you have touched this file. Can you please help us figure out what might be causing this issue and how can we fix it?

Thanks.
No longer blocks: 1240787
Flags: needinfo?(n.nethercote)
Sorry, messed in activity collision.
Blocks: 1240787
Summary: Crash on startup. → Crash on startup: Assertion failure: mInUpdate (Ending update while not in update), at widget/cocoa/nsChildView.mm:2965
I have touched this file recently, but only for refactorings that involve changing types in ways that are unlikely to trigger crashes. If this is a regression, are you able to bisect down to the regressing patch? That would be extremely helpful.
I'd suspect bug 1238755, bug 1238753, or bug 1187322, if you want to gamble and shorten the bisection range ;)
Attached patch fix-basicSplinter Review
Assignee: nobody → matt.woodrow
Attachment #8711507 - Flags: review?(mstange)
On trivial testing, I don't see the crash anymore.
Duplicate of this bug: 1240787
Flags: needinfo?(n.nethercote)
Comment on attachment 8711507 [details] [diff] [review]
fix-basic

Review of attachment 8711507 [details] [diff] [review]:
-----------------------------------------------------------------

oops, thanks
Attachment #8711507 - Flags: review?(mstange) → review+
Blocks: 1238753
No longer blocks: 1240787
Summary: Crash on startup: Assertion failure: mInUpdate (Ending update while not in update), at widget/cocoa/nsChildView.mm:2965 → Debug builds crash on startup: Assertion failure: mInUpdate (Ending update while not in update), at widget/cocoa/nsChildView.mm:2965
Comment on attachment 8711507 [details] [diff] [review]
fix-basic

Approval Request Comment
[Feature/regressing bug #]: bug 1238753 (part of BasicCompositor on OS X)
[User impact if declined]: debug builds print assertions if hardware acceleration is off
[Describe test coverage new/current, TreeHerder]: none (we don't run any tests with hardware acceleration disabled on OS X)
[Risks and why]: extremely low, simple null check
[String/UUID change made/needed]: none
Attachment #8711507 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/c45623c0cb55
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 46.0
Duplicate of this bug: 1242769
If bug 1238753 is uplifted then please request uplift for this as well ( to 45 beta)
Comment on attachment 8711507 [details] [diff] [review]
fix-basic

Approval Request Comment
[Feature/regressing bug #]:
[User impact if declined]:
[Describe test coverage new/current, TreeHerder]:
[Risks and why]: 
[String/UUID change made/needed]:

Small fix for graphics regression, please uplift to aurora.
Attachment #8711507 - Flags: approval-mozilla-beta?
Attachment #8711507 - Flags: approval-mozilla-aurora?
Attachment #8711507 - Flags: approval-mozilla-aurora+
Comment on attachment 8711507 [details] [diff] [review]
fix-basic

Taking it in beta
Should be in 45 beta 3.
Attachment #8711507 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Moving product to Firefox temporarily so I can set the firefox status flags so this gets out of my uplift queries. Will move it back to thunderbird afterwards.
Product: Thunderbird → Firefox
Target Milestone: Thunderbird 46.0 → ---
Product: Firefox → Thunderbird
Target Milestone: --- → Thunderbird 47.0
You need to log in before you can comment on or make changes to this bug.