Closed Bug 1242358 Opened 7 years ago Closed 6 years ago

Inner substring search is not working

Categories

(Firefox OS Graveyard :: Gaia::TV, defect, P3)

ARM
Gonk (Firefox OS)
defect

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: cbadescu, Unassigned)

References

Details

(Whiteboard: [ft:conndevices])

Steps to reproduce:
1.In “Dev Web Apps” navigate to an app with video content i.e: “Craft Smart” and press “OK”(“Enter” key on the keyboard).
2.In app content go to search icon and press “OK”(“Enter” key on the keyboard).
3.Perform a search using a substring of a video title (i.e: For the Video called Polar Bear Play-Doh perform a search using the inner substring “bea”).


Expected results:
Some search results should be displayed after introduced search criteria

Actual results:
No results are shown in search result

Note/Issues:
Environment: 2.5 Simulator.
This issue is reproducing in -dev server.
Only exact matching strings are found (i.e:  A video called polar bear can be found only if searched using the full title or the first word. Searching for “bea” will not return anything).
No longer blocks: TV_Marketplace_2.5
Priority: -- → P3
It's a content issue, not WebApps issue.
Michael, are you the right person to deal with content issue?
Flags: needinfo?(mellis)
Blocks: 1243809
Thanks for reporting this issue, we will notify the content partner.
Whiteboard: [ft:conndevices]
Partner has not yet responded to pings over email.

@BD - to reignite this conversation
Flags: needinfo?(mellis) → needinfo?(schiba)
Since web apps won't in 2.6 scope, this issue is not valid anymore after removing web apps from our build.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → INVALID
Flags: needinfo?(schiba)
You need to log in before you can comment on or make changes to this bug.