Closed Bug 1242469 Opened 6 years ago Closed 6 years ago

Remove the "Enable worker debugging (in development)" checkbox from about:debugging

Categories

(DevTools :: about:debugging, defect)

defect
Not set
normal

Tracking

(firefox47 verified)

VERIFIED FIXED
Firefox 47
Tracking Status
firefox47 --- verified

People

(Reporter: janx, Assigned: janx)

Details

Attachments

(1 file)

This checkbox controls the "devtools.debugger.workers" pref, which we should remove as well.
Eddy, do you know what this pref controls? Can we get rid of it?
Flags: needinfo?(ejpbruel)
(In reply to Jan Keromnes [:janx] from comment #1)
> Eddy, do you know what this pref controls? Can we get rid of it?

That pref controls whether or not we show the worker debugger UI. I am reluctant to remove it at this point, mostly because I don't think that we offer a good user experience for worker debugging yet.
Flags: needinfo?(ejpbruel)
Fair enough, thanks Eddy.

However, since it's related to debugging plain JS workers on a website, and not launching toolboxes on service workers from about:debugging, I'll remove the checkbox from about:debugging (another checkbox remains in the toolbox options) because it's misleading and confusing to users of about:debugging.
Assignee: nobody → janx
Attachment #8711673 - Flags: review?(poirot.alex) → review+
Trivial patch with all-green try.
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/acd0c697f16c
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 47
I have reproduced this bug on Nightly 47.0a1 (2016-01-25) on ubuntu 14.04 LTS, 32 bit!

The bug's fix is now verified on Latest Developer Edition 47.0a2!

Build ID: 20160414004009
User Agent: Mozilla/5.0 (X11; Linux i686; rv:47.0) Gecko/20100101 Firefox/47.0
QA Whiteboard: [testday-20160415]
I have reproduced this bug with Firefox Nightly 47.0a1 (Build ID: 20160125060632) on 
Windows 8.1, 64-bit.

Verified as fixed with Firefox Developer edition 47.0a2 (Build ID: 20160420004046)
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0

As the bug is also verified on Linux (comment 9), I am marking this as verified!
Status: RESOLVED → VERIFIED
QA Whiteboard: [testday-20160415] → [testday-20160415][bugday-20160420]
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.