Closed Bug 1242523 Opened 5 years ago Closed 5 years ago

crash in ZoomConstraintsClient::RefreshZoomConstraints

Categories

(Core :: Panning and Zooming, defect)

Unspecified
Android
defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla47
Tracking Status
firefox44 --- affected
firefox45 + fixed
firefox46 + fixed
firefox47 --- fixed
fennec 45+ ---

People

(Reporter: snorp, Assigned: kats)

References

Details

(Keywords: crash)

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-37c7de8b-44a3-4652-8d75-7542f2160119.
=============================================================

This is showing up for Fennec in Aurora
tracking-fennec: --- → ?
Probably mPresShell is null because it got Destroy()'d in between the task getting posted and it getting run.
Assignee: nobody → bugmail.mozilla
Component: Graphics → Panning and Zooming
Although if my theory was correct I wouldn't expect so many crashes. Some of the comments in the crash reports (e.g. "Closing Firefox down with Clean Quit. ") seem to imply it's a shutdown crash. It might be that the "clean quit" is resetting the pref on shutdown right around when the ZCC is destroyed. I'll try to reproduce this.
Wasn't able to repro. I'll just put together a speculative fix.
Attached patch PatchSplinter Review
Attachment #8711774 - Flags: review?(snorp)
Attachment #8711774 - Flags: review?(snorp) → review+
https://hg.mozilla.org/mozilla-central/rev/b50153f2caf7
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla46
Target Milestone: mozilla46 → mozilla47
[Tracking Requested - why for this release]: fix for a crasher
tracking-fennec: ? → 45+
Comment on attachment 8711774 [details] [diff] [review]
Patch

Approval Request Comment
[Feature/regressing bug #]: bug 1197824
[User impact if declined]: crashes during shutdown, apparently. I can't reproduce but there are a bunch of these on crash-stats.
[Describe test coverage new/current, TreeHerder]: minimal
[Risks and why]: extremely low risk patch, just a null check. it's a speculative fix, not sure if it will resolve the issue but I think we should uplift and monitor crash-stats to see.
[String/UUID change made/needed]: none
Attachment #8711774 - Flags: approval-mozilla-beta?
Attachment #8711774 - Flags: approval-mozilla-aurora?
Crash, tracking it.
Comment on attachment 8711774 [details] [diff] [review]
Patch

Fix (hopefully) a crash, taking it.
Should be in 45 beta 2.
Attachment #8711774 - Flags: approval-mozilla-beta?
Attachment #8711774 - Flags: approval-mozilla-beta+
Attachment #8711774 - Flags: approval-mozilla-aurora?
Attachment #8711774 - Flags: approval-mozilla-aurora+
According to crash-stats the fix seems to have worked for Fennec. There's some crashes in 45.0b2 and onwards for desktop still.
You need to log in before you can comment on or make changes to this bug.