Closed Bug 124264 Opened 19 years ago Closed 18 years ago

Clicking on popup link stops first page from loading to completion

Categories

(SeaMonkey :: General, defect)

x86
All
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: osavill, Assigned: asa)

References

()

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8+) Gecko/20020204
BuildID:    2002020421

Clicking on a link on a page that produces a popup window prevents the page from
loading any further. As soon as the popup window starts to load its data the
first page just stops loading any further and the M icon stops animating.

Reproducible: Always
Steps to Reproduce:
1.Goto the above URL.
2.While the pictures are still loading click on one of the blue highlighted prices.
3.

Actual Results:  The popup window appears and starts to load.

The above URL stops loading

Expected Results:  Both windows should load to completion
Reporter () can you check to see whether this bug is still present in a recent
build (Moz1-RC1 or a new nightly build). If this bug does not occur please can
you resolve it worksforme. Thanks.
wfm, as nobody can reproduce it. reopen if you can.
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → WORKSFORME
Yes, I can.  Goto http://www.denzilgrant.com/cgi-bin/RenderPages/Render?Tables.csv?1 and click on one of the price links BEFORE the pictures have finished loading.  Result: The small popup window appears populated with the price ready for conversion, BUT the main page has stopped loading so not all the images are visible. 
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
Reproducable on Windows 2000, using Mozilla 1.1b, build id 2002080308.

However, I don't think this is a bug, as such - the price links on the page have
URLs (all be it JavaScript ones) meaning the browser will stop loading the
current page when you click them. This is the indended behaviour (as far as I know).

Marking WONTFIX, since the reported problem is reproducable, but it's the
intended behaviour. If this isn't satisfactory (to the reporter), I suggest you
re-open this bug as "[RFE] Don't stop loading page when navigating to a
JavaScript URL" or similar (unless there is already a bug for that...).
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago18 years ago
OS: Linux → All
Resolution: --- → WONTFIX
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.