Support info doesn't show up on an empty profile

RESOLVED WONTFIX

Status

P3
normal
RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: krupa.mozbugs, Assigned: spasovski)

Tracking

2016-02-02
x86
All
Points:
---

Details

(URL)

(Reporter)

Description

3 years ago
steps to reproduce:
1. Start a fresh profile on Firefox with no data on it
2. Load https://marketplace-dev.allizom.org/app/en-gb-el-ee-dsb-de-da-cy-cs-99/?src=search
3. Look for the Email Support link or Support Site link.


expected behavior:

Email Support link or Support Site link is listed for every public app since it is a required field

actual behavior:
This info is missing on a fresh profile

This is causing our automated test to fail
Is this a regression?
Assignee: nobody → dspasovski
Flags: needinfo?(krupa.mozbugs)
Priority: -- → P3
Target Milestone: --- → 2016-02-02
Our automation is no longer failing due to the email support link or support site link. The most recent failures are due to the application description being missing. At the moment the test just uses the first result from a search of ":free", which is likely to be a different app over time and the data associated with the apps will vary. I think we should either generate an app via the API to use for the test, or relax the checks to only fields that are expected to be common across all apps.
If the test is going away, then this should too.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(krupa.mozbugs)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.