Closed Bug 1242768 Opened 6 years ago Closed 4 months ago

Intel crash in D3D10::CResourceCopy::ResourceCopyRegionGPU

Categories

(Core :: Graphics, defect, P3)

44 Branch
x86
Windows NT
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
platform-rel --- +
firefox44 --- affected
firefox45 --- affected
firefox47 --- affected
firefox48 --- affected
firefox49 --- affected
firefox-esr45 --- affected
firefox50 --- affected
firefox51 --- affected
firefox52 --- wontfix

People

(Reporter: philipp, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: crash, Whiteboard: [gfx-noted] [platform-rel-Intel])

Crash Data

This bug was filed from the Socorro interface and is 
report bp-2c230112-8401-4bac-aa29-80f142160119.
=============================================================
Crashing Thread (18)
Frame 	Module 	Signature 	Source
0 	igd10umd32.dll 	D3D10::CResourceCopy::ResourceCopyRegionGPU(D3D10::CResource*, unsigned long, unsigned long, unsigned long, unsigned long, D3D10::CResource*, unsigned long, D3D10_DDI_BOX const*) 	
1 	igd10umd32.dll 	D3D10::CDevice::ResourceUpdateSubResourceUP(D3D10::CResource*, unsigned int, D3D10_DDI_BOX const*, void const*, unsigned int, unsigned int, int) 	
2 	igd10umd32.dll 	D3D10API::ResourceUpdateSubResourceUP10(D3D10DDI_HDEVICE, D3D10DDI_HRESOURCE, unsigned int, D3D10_DDI_BOX const*, void const*, unsigned int, unsigned int) 	
3 	d3d11.dll 	CContext::ID3D11DeviceContext1_UpdateSubresource_<0>(ID3D11DeviceContext1*, ID3D11Resource*, unsigned int, D3D11_BOX const*, void const*, unsigned int, unsigned int) 	
4 	xul.dll 	mozilla::layers::DataTextureSourceD3D11::Update(mozilla::gfx::DataSourceSurface*, nsIntRegion*, mozilla::gfx::IntPointTyped<mozilla::gfx::UnknownUnits>*) 	gfx/layers/d3d11/TextureD3D11.cpp
5 	xul.dll 	mozilla::layers::BufferTextureHost::Upload(nsIntRegion*) 	gfx/layers/composite/TextureHost.cpp
6 	xul.dll 	mozilla::layers::BufferTextureHost::MaybeUpload(nsIntRegion*) 	gfx/layers/composite/TextureHost.cpp
7 	xul.dll 	mozilla::layers::BufferTextureHost::UpdatedInternal(nsIntRegion const*) 	gfx/layers/composite/TextureHost.cpp
8 		@0x9bd9ffc6 	
9 	xul.dll 	mozilla::layers::CompositableParentManager::ReceiveCompositableUpdate(mozilla::layers::CompositableOperation const&, std::vector<mozilla::layers::EditReply, std::allocator<mozilla::layers::EditReply> >&) 	gfx/layers/ipc/CompositableTransactionParent.cpp
10 	xul.dll 	mozilla::layers::LayerTransactionParent::RecvUpdate(nsTArray<mozilla::layers::Edit>&&, unsigned __int64 const&, mozilla::layers::TargetConfig const&, nsTArray<mozilla::layers::PluginWindowData>&&, bool const&, bool const&, unsigned int const&, bool const&, mozilla::TimeStamp const&, int const&, nsTArray<mozilla::layers::EditReply>*) 	gfx/layers/ipc/LayerTransactionParent.cpp
11 	xul.dll 	mozilla::layers::LayerTransactionParent::RecvUpdate(nsTArray<mozilla::layers::Edit>&&, unsigned __int64 const&, mozilla::layers::TargetConfig const&, nsTArray<mozilla::layers::PluginWindowData>&&, bool const&, bool const&, unsigned int const&, bool const&, mozilla::TimeStamp const&, int const&, nsTArray<mozilla::layers::EditReply>*) 	gfx/layers/ipc/LayerTransactionParent.cpp
12 	xul.dll 	MessageLoop::DoWork() 	ipc/chromium/src/base/message_loop.cc

this is a low level graphics crash on intel gpus which has been around for a bit, but it has some clear correlations, so maybe it is actionable based on that. 
user comments often link the crash to watching videos, on youtube for example.

correlations from crashes after 2016-01-01:
Adapter driver version facet Rank 	Adapter driver version 	Count 	%
1 	8.15.10.1749 	2799 	99.64 %
2 	8.15.10.1662 	8 	0.28 %

Adapter device id facet Rank 	Adapter device id 	Count 	%
1 	0x2a12 	1044 	37.17 %
2 	0x2a02 	705 	25.10 %
3 	0x2a42 	488 	17.37 %
4 	0x2e32 	176 	6.27 %
5 	0x2e12 	162 	5.77 %
6 	0x2982 	131 	4.66 %
7 	0x2e22 	103 	3.67 %
This looks like a duplicate of bug 1202700, but that's supposed to have been fixed in 43.  Unless we backed something out.
Flags: needinfo?(matt.woodrow)
Flags: needinfo?(bas)
See Also: → 1202700
Whiteboard: [gfx-noted]
(In reply to Milan Sreckovic [:milan] from comment #1)
> This looks like a duplicate of bug 1202700, but that's supposed to have been
> fixed in 43.  Unless we backed something out.

1202700 looks orthogonal to me. Can I get a minidump for this?
Flags: needinfo?(bas)
Bas is going to have a look at the minidump.
Flags: needinfo?(matt.woodrow)
I investigated the minidump here. We -are- doing a partial upload of the texture here. Which is somewhat interesting. It's tempting to believe this is related to there being a problem. Having said that however I don't see anything wrong with parameters being passed. Nothing related to null is being given to the intel driver yet this is clearly a null pointer dereference.

This is similar to another intel crash I've looked at, it definitely seems like a driver bug.
(In reply to Bas Schouten (:bas.schouten) from comment #4)
> This is similar to another intel crash I've looked at, it definitely seems like a driver bug.

Is this something we should escalate to Intel?
Flags: needinfo?(milan)
(In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #5)
> (In reply to Bas Schouten (:bas.schouten) from comment #4)
> > This is similar to another intel crash I've looked at, it definitely seems like a driver bug.
> 
> Is this something we should escalate to Intel?

Yes, that's what blocking bug 1243903 is for.
Flags: needinfo?(milan)
Whiteboard: [gfx-noted] → [gfx-noted [platform-rel-Intel]
platform-rel: --- → ?
Crash volume for signature 'D3D10::CResourceCopy::ResourceCopyRegionGPU':
 - nightly(version 50):0 crashes from 2016-06-06.
 - aurora (version 49):14 crashes from 2016-06-07.
 - beta   (version 48):395 crashes from 2016-06-06.
 - release(version 47):1585 crashes from 2016-05-31.
 - esr    (version 45):95 crashes from 2016-04-07.

Crash volume on the last weeks:
            W. N-1  W. N-2  W. N-3  W. N-4  W. N-5  W. N-6  W. N-7
 - nightly       0       0       0       0       0       0       0
 - aurora        2       6       1       1       1       1       2
 - beta         61      99      38      34      48      49      37
 - release     222     193     222     172     211     243     232
 - esr          10      11       9       8      12      18      11

Affected platform: Windows
platform-rel: ? → +
Crash volume for signature 'D3D10::CResourceCopy::ResourceCopyRegionGPU':
 - nightly (version 51): 1 crash from 2016-08-01.
 - aurora  (version 50): 23 crashes from 2016-08-01.
 - beta    (version 49): 119 crashes from 2016-08-02.
 - release (version 48): 252 crashes from 2016-07-25.
 - esr     (version 45): 105 crashes from 2016-05-02.

Crash volume on the last weeks (Week N is from 08-22 to 08-28):
            W. N-1  W. N-2  W. N-3
 - nightly       0       1       0
 - aurora        3      12       1
 - beta         44      39      17
 - release      74      85      41
 - esr           2       1       4

Affected platform: Windows

Crash rank on the last 7 days:
           Browser   Content     Plugin
 - nightly
 - aurora            #68
 - beta    #484      #243
 - release #303      #427
 - esr     #964
Crash volume for signature 'D3D10::CResourceCopy::ResourceCopyRegionGPU':
 - nightly (version 52): 1 crash from 2016-09-19.
 - aurora  (version 51): 0 crashes from 2016-09-19.
 - beta    (version 50): 25 crashes from 2016-09-20.
 - release (version 49): 140 crashes from 2016-09-05.
 - esr     (version 45): 174 crashes from 2016-06-01.

Crash volume on the last weeks (Week N is from 10-03 to 10-09):
            W. N-1  W. N-2
 - nightly       1       0
 - aurora        0       0
 - beta         19       6
 - release     106      34
 - esr           8      17

Affected platform: Windows

Crash rank on the last 7 days:
           Browser   Content     Plugin
 - nightly           #440
 - aurora
 - beta    #728      #861
 - release #586      #465
 - esr     #915
Rank: 11
These seem to have disappeared from 51 and 52, but lets see if that changes when we roll 51 to beta next week.  We made some changes to video that could account for this.
Too late for firefox 52, mass-wontfix.
Whiteboard: [gfx-noted [platform-rel-Intel] → [gfx-noted] [platform-rel-Intel]

Marking this as Resolved > Worksforme since no other crashes with this signature have been reported in the last 6 months.

Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.