Closed Bug 1242794 Opened 6 years ago Closed 6 years ago

SkBitmap.cpp:897: failed assertion "fPixelRef->info() == pixelRef->info()"

Categories

(Core :: Canvas: 2D, defect)

defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla47
Tracking Status
firefox47 --- fixed

People

(Reporter: jruderman, Assigned: lsalzman)

References

(Blocks 1 open bug)

Details

(Keywords: assertion, regression, testcase, Whiteboard: [gfx-noted])

Attachments

(3 files)

Attached file testcase
gfx/skia/skia/src/core/SkBitmap.cpp:897: failed assertion "fPixelRef->info() == pixelRef->info()"
Attached file stack
fAlphaType differs (kPremul_SkAlphaType vs kOpaque_SkAlphaType).
Whiteboard: [gfx-noted]
Since Skia upstream is working on removing SkGrPixelRef entirely, any changes to it are a bit controversial and whether or not it will get upstreamed quickly or at all is unknown.

But let's just get this fix in-tree anyway until such time as we can replace SkBitmap with SkImage.

Unfortunately, SkImage also is implemented in terms of SkBitmap right now too, so I think this bug would still hit it even when we do that port... more incentive to just incorporate this fix for now.
Assignee: nobody → lsalzman
Status: NEW → ASSIGNED
Attachment #8713198 - Flags: review?(jmuizelaar)
Attachment #8713198 - Flags: review?(jmuizelaar) → review+
https://hg.mozilla.org/mozilla-central/rev/56ed844ad5dd
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla47
You need to log in before you can comment on or make changes to this bug.