ASSERTION: no m_path, see bugs #57659 and #72317: 'm_path', file /home/timeless/mozilla/mailnews/news/src/nsNNTPProtocol.cpp, line 2180

VERIFIED WONTFIX

Status

MailNews Core
Networking: NNTP
VERIFIED WONTFIX
17 years ago
8 years ago

People

(Reporter: timeless, Unassigned)

Tracking

({assertion})

Trunk
x86
FreeBSD
assertion

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
fbsd cvs build from today. I was debugging another bug which meant that my mozilla mail client was suspended for a while. I got this when i continued after a long pause. [i suspect my news.mozilla.org connection timed out]

The thing is, the two bugs referenced are both resolved as duplicates of other bugs, so could you at least update the assert to suggest a new bug?

#2  0x282db645 in nsDebug::Assertion (aStr=0x2ab6ebe0 "no m_path, see bugs #57659 and #72317", aExpr=0x2ab6ebd2 "m_path",
    aFile=0x2ab6e200 "/home/timeless/mozilla/mailnews/news/src/nsNNTPProtocol.cpp", aLine=2180) at /home/timeless/mozilla/xpcom/base/nsDebug.cpp:291
#3  0x2ab14861 in nsNNTPProtocol::SendFirstNNTPCommand (this=0x9262c00, url=0x8d97c04) at /home/timeless/mozilla/mailnews/news/src/nsNNTPProtocol.cpp:2180
#4  0x2ab220f4 in nsNNTPProtocol::ProcessProtocolState (this=0x9262c00, url=0x8d97c04, inputStream=0x916f790, sourceOffset=21130, length=53)
    at /home/timeless/mozilla/mailnews/news/src/nsNNTPProtocol.cpp:5115
#5  0x2a7d65c9 in nsMsgProtocol::OnDataAvailable (this=0x9262c0c, request=0x9218380, ctxt=0x8d97c00, inStr=0x916f790, sourceOffset=21130, count=53)
    at /home/timeless/mozilla/mailnews/base/util/nsMsgProtocol.cpp:264
#6  0x28bef85d in nsOnDataAvailableEvent::HandleEvent (this=0x98567c0) at /home/timeless/mozilla/netwerk/base/src/nsStreamListenerProxy.cpp:193
#7  0x28bda408 in nsARequestObserverEvent::HandlePLEvent (plev=0x98567c0) at /home/timeless/mozilla/netwerk/base/src/nsRequestObserverProxy.cpp:115
#8  0x282cb5cd in PL_HandleEvent (self=0x98567c0) at /home/timeless/mozilla/xpcom/threads/plevent.c:590
#9  0x282cb3b4 in PL_ProcessPendingEvents (self=0x817a880) at /home/timeless/mozilla/xpcom/threads/plevent.c:520
#10 0x282cd8b0 in nsEventQueueImpl::ProcessPendingEvents (this=0x817a840) at /home/timeless/mozilla/xpcom/threads/nsEventQueue.cpp:388
#11 0x289f75ea in event_processor_callback (data=0x817a840, source=6, condition=GDK_INPUT_READ) at /home/timeless/mozilla/widget/src/gtk/nsAppShell.cpp:184
#12 0x289f7165 in our_gdk_io_invoke (source=0x8161780, condition=G_IO_IN, data=0x8161770) at /home/timeless/mozilla/widget/src/gtk/nsAppShell.cpp:77
#13 0x2855365c in g_io_unix_dispatch () from /usr/local/lib/libglib12.so.3
#14 0x28554d03 in g_main_dispatch () from /usr/local/lib/libglib12.so.3
#15 0x2855532c in g_main_iterate () from /usr/local/lib/libglib12.so.3
#16 0x285554c4 in g_main_run () from /usr/local/lib/libglib12.so.3
#17 0x284758b7 in gtk_main () from /usr/X11R6/lib/libgtk12.so.2
#18 0x289f7d8d in nsAppShell::Run (this=0x80cf380) at /home/timeless/mozilla/widget/src/gtk/nsAppShell.cpp:364
(Reporter)

Updated

17 years ago
Keywords: assertion
Confirming.  Timeless, wait on this, Seth's on vacation until the end of this
week, I think.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 3

17 years ago
Comment on attachment 69104 [details] [diff] [review]
Patch which updates the assertion to point to bug 73920 and bug 72320.

sounds good to me. don't worry, i have no interest in checking this in.
Attachment #69104 - Flags: review+

Comment 4

14 years ago
*** Bug 76539 has been marked as a duplicate of this bug. ***
(Reporter)

Updated

14 years ago
Attachment #69104 - Flags: superreview?(neil.parkwaycc.co.uk)

Updated

14 years ago
Attachment #69104 - Flags: superreview?(neil.parkwaycc.co.uk) → superreview+
Product: MailNews → Core
sorry for the spam.  making bugzilla reflect reality as I'm not working on these bugs.  filter on FOOBARCHEESE to remove these in bulk.
Assignee: sspitzer → nobody
Filter on "Nobody_NScomTLD_20080620"
QA Contact: stephend → networking.news
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core
My news URI parsing work is removing the assertion altogether (since m_path is being removed).
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
(Reporter)

Updated

8 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.