[TV][2.5][Web Apps] Cannot use back key in Web Apps from real TV

RESOLVED WORKSFORME

Status

P1
normal
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: mlien, Assigned: rickychien)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.5+)

Details

(Whiteboard: [ft:conndevices])

(Reporter)

Description

3 years ago
[Description]
Back key in Web Apps from real TV cannot work

[Reproduce Steps]
1. Launch Apps -> Web Apps/Dev Web Apps
2. Open any app/website
3. Go to different pages
4. Press back key to previous page

[Build Information]
Environment: Real TV 2016 Model

[Expected Result]
It can go back to previous page

[Actual Result]
Back key doesn't work
(Reporter)

Comment 1

3 years ago
Simulator doesn't have this problem
NI Ricky for all things Back button related.
Blocks: 1187806
No longer blocks: 1204762
Flags: needinfo?(rchien)
(Assignee)

Comment 3

3 years ago
Because we are unable to recognize the key if real TV sent an "unidentified" key event. This problem will be addressed in bug 1238870 by checking keyCode instead.
Depends on: 1238870
Flags: needinfo?(rchien)

Updated

3 years ago
Assignee: nobody → rchien
(Reporter)

Updated

3 years ago
QA Whiteboard: [COM=TV::Web Apps]

Updated

3 years ago
blocking-b2g: --- → 2.5+
(Reporter)

Updated

3 years ago
Depends on: 1244033

Comment 4

3 years ago
Update: Partner is trying to introduce the patch to their repository.

Updated

3 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 5

3 years ago
Fixed in bug 1238870 and verified on real TV.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.