Replace {{Xref_cssgradient}} occurrences with {{cssxref("<gradient>")}}

RESOLVED FIXED

Status

RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: teoli, Assigned: slayslot, Mentored)

Tracking

Details

(Whiteboard: [good first bug])

(Reporter)

Description

3 years ago
We have 50 occurrences of {{xref_cssgradient}}, a macro we want to delete [1].

This task is about to go on each of these MDN pages, to edit the page and to replace the occurrence of {{xref_cssgradient}} with {{cssxref("<gradient>")}}, to save it and to check that the link is working.

You need an MDN account and the ability to use a WYSIWYG editor to perform this task.

[1] https://developer.mozilla.org/en-US/search?locale=*&kumascript_macros=xref_cssgradient

Comment 1

3 years ago
Hello, I would like to take this bug for: University of Toronto, CSC302H1S-2015
assignment. Patch by Feb 26,2016
Hey Cody,

Thanks for the interest. This is a documentation bug, where you need to create an account on MDN (Mozilla Developer Network - developer.mozilla.org) and you can just edit the wiki pages to make the fix needed for the bug. Since this isn't a coding task, there isn't any patch needed for this.

(If you are looking only for coding/development kind of tasks, check out http://www.joshmatthews.net/bugsahoy/ and pick a category other than "MDN/Developer Documentation")
Mentor: sebastianzartner
(Assignee)

Comment 3

3 years ago
Hi, I can pick this up if it's not assigned to anyone.
Great! I assigned you. Feel free to ask me if you have any questions.

Sebastian
Assignee: nobody → nikhil.handa19
(Assignee)

Comment 5

3 years ago
Thank you for the quick reply. I went to MDN and saw that creation of new account is unavailable as of now. What should I do now?
You should ask at the dev-mdc mailing list for an account (and refer to this bug report):

https://lists.mozilla.org/listinfo/dev-mdc

(Unfortunately I don't have the rights to create an account for you.)

Sebastian
(Assignee)

Comment 7

3 years ago
Posted, awaiting a reply.
(Assignee)

Comment 8

3 years ago
Thank you Sebastian for guiding me. Thanks to Eric Shepherd, I was able to make an account on MDN successfully. I think I've successfully changed two occurrences[1] of {{xref_cssgradient}}. Since, this is my first time editing on MDN, I would request that you confirm that the two occurrences are successfully replaced and that I've not missed out on anything. Once confirmed that I'm on the correct track, the remaining 48 occurrences shall be a breeze.

[1] https://developer.mozilla.org/en-US/docs/Web/CSS/image
> [1] https://developer.mozilla.org/en-US/docs/Web/CSS/image

Looks good. It will be fine to proceed the same way for the rest of the pages.
(Assignee)

Comment 10

3 years ago
Thanks for the quick reply, Saurabh. So, I've replaced all the `{{xref_cssgradient}}` occurrences with `{{cssxref("<gradient>")}}`. What is left in the search [1] is `{{ xref_cssgradient() }}` occurrences. Now, should I replace these as well? If yes, should it be with `{{cssxref("<gradient>")}}` or something different? Thanks.

[1] https://developer.mozilla.org/en-US/search?locale=*&kumascript_macros=xref_cssgradient
Hey,

You can replace `{{ xref_cssgradient() }}` also with `{{cssxref("<gradient>")}}`. AFAIK, if a macro doesn't have any params passed, the parenthesis can be ignored. So xref_cssgradient() is the same as xref_cssgradient.
(Assignee)

Comment 12

3 years ago
Hello,

Thanks again for the quick reply, Saurabh. I've successfully replace all occurrences of `{{xref_cssgradient}}` with `{{cssxref("<gradient>")}}`, as can be seen in the search [1]. One page [2] seems to be having a script error so the link is not working there. All other occurrences were successfully replaced and were found working.

[1] https://developer.mozilla.org/en-US/search?locale=*&kumascript_macros=xref_cssgradient
[2] https://developer.mozilla.org/fr/docs/Web/CSS/image
I fixed the macro error. Thanks for all the work :)
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Hi Nikhil,

sorry for not replying earlier. I was on vacations until yesterday.
Thank you for making the changes!

One note for future page edits: Please add a revision comment when saving your changes. This makes it easier to track page changes.

Sebastian
(Assignee)

Comment 15

3 years ago
Hi Sebastian,

I will surely keep that in mind :)
See Also: → bug 1283051
Blocks: 1213569
You need to log in before you can comment on or make changes to this bug.