crash in shutdownhang | WaitForSingleObjectEx | WaitForSingleObject | CSCardSubcontext::WaitForAvailable | CSCardSubcontext::ReleaseContext caused by wdpkcs.dll - Watchdata's PKI

RESOLVED INVALID

Status

Thunderbird
General
--
critical
RESOLVED INVALID
2 years ago
a year ago

People

(Reporter: wsmwk, Unassigned)

Tracking

({crash, topcrash-thunderbird})

38 Branch
x86
Windows NT
crash, topcrash-thunderbird

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

2 years ago
#21 crash for 38.5.1. All crashes are MS Windows
estimate 10-20% of crashes are from users in Brazil (have ".br" in email address)

A few crashes have mentioned password. but most have significant uptime.  

most users who have supplied email addresses crash multiple times per week. for example these users:
bp-ac115d8a-9578-408b-b7e7-2a0562160122
bp-3f80bafa-bcf7-4128-b4c8-c82842160106
bp-755a2cc5-e156-4424-94e8-775682160118 (only 74sec uptime)
bp-c3fdaff0-5c41-4aec-917f-1f1e72160118

Comment 1

2 years ago
I'm very confused by the signature with CSCardSubcontext as I cannot find this string in our code at all. Otherwise it looks like our generic timeout crash at shutdown.
(In reply to Kent James (:rkent) from comment #1)
> I'm very confused by the signature with CSCardSubcontext as I cannot find
> this string in our code at all. Otherwise it looks like our generic timeout
> crash at shutdown.

Maybe, user uses smart card via NSS.  Same hang occurs on Firefox too (ex. bp-82996a49-aab0-4706-be91-6bf2a2160120).  This isn't thunderbird issue.
This issue will be wdpkcs.dll.  wdpkcs.dll seems to be Watchdata's PKI.

Comment 4

2 years ago
I assume then we should list this as invalid.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
(Reporter)

Comment 5

2 years ago
(In reply to Makoto Kato [:m_kato] from comment #3)
> This issue will be wdpkcs.dll.  wdpkcs.dll seems to be Watchdata's PKI.

sadly, this is still a topcrash - #12 for 45.2.0. And that's only win8-10**, without version 7. Unclear if the problem occurs for win7.

**Windows 10	566	77.9%
Windows 8.1	131	18.0%
Windows 8	30	4.1%

Other signatures - both low rate
shutdownhang | NtWaitForAlertByThreadId | RtlpWaitOnAddressWithTimeout | RtlpWaitOnAddress | RtlpWaitOnCriticalSection | RtlpEnterCriticalSectionContended | RtlEnterCriticalSection | RedirectionContextRelease
shutdownhang | RtlpWaitOnCriticalSection | RtlpEnterCriticalSectionContended | ntdll.dll@0x1dc64
Summary: crash in shutdownhang | WaitForSingleObjectEx | WaitForSingleObject | CSCardSubcontext::WaitForAvailable | CSCardSubcontext::ReleaseContext → crash in shutdownhang | WaitForSingleObjectEx | WaitForSingleObject | CSCardSubcontext::WaitForAvailable | CSCardSubcontext::ReleaseContext caused by wdpkcs.dll - Watchdata's PKI
(Reporter)

Comment 6

a year ago
Another signature shutdownhang | CSCardSubcontext::WaitForAvailable | CSCardSubcontext::ReleaseContext
bp-34bb3f1c-9965-4741-bc6c-275e52161111  50.0b3
Crash Signature: [@ shutdownhang | WaitForSingleObjectEx | WaitForSingleObject | CSCardSubcontext::WaitForAvailable | CSCardSubcontext::ReleaseContext] → [@ shutdownhang | WaitForSingleObjectEx | WaitForSingleObject | CSCardSubcontext::WaitForAvailable | CSCardSubcontext::ReleaseContext] [@ shutdownhang | CSCardSubcontext::WaitForAvailable | CSCardSubcontext::ReleaseContext]
You need to log in before you can comment on or make changes to this bug.