Closed Bug 1243070 Opened 4 years ago Closed 4 years ago

Convert SIZE_CHANGED event to native method

Categories

(Core :: Widget: Android, defect)

All
Android
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla47
Tracking Status
firefox47 --- fixed

People

(Reporter: jchen, Assigned: jchen)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

Convert the SIZE_CHANGED GeckoEvent to a native method call.
Convert the SIZE_CHANGED event to a native method in GLController, and
carry over the SIZE_CHANGED implementation to the new implementation in
GLController. Some other changes were made for correctness in handling
size changes.
Attachment #8712294 - Flags: review?(snorp)
Remove obsolete SIZE_CHANGED event and its handler in nsWindow. Also
remove some other supporting code (such as gAndroidBounds and the
FORCED_RESIZE event) that should be unnecessary by now.
Attachment #8712295 - Flags: review?(snorp)
Attachment #8712294 - Flags: review?(snorp) → review+
Attachment #8712295 - Flags: review?(snorp) → review+
Duplicate of this bug: 1206742
https://hg.mozilla.org/mozilla-central/rev/9f0bf58364c7
https://hg.mozilla.org/mozilla-central/rev/9d7a310cb701
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla47
You need to log in before you can comment on or make changes to this bug.