Closed Bug 1243087 Opened 4 years ago Closed 4 years ago

Migrate Smart-Home to L20n.js

Categories

(Firefox OS Graveyard :: Gaia::TV::Home, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: zbraniecki, Assigned: zbraniecki)

References

Details

Attachments

(1 file)

No description provided.
With the last mozL10n.get we have to wait for bug 1216150 to land.
Depends on: 1216150
Summary: Move away from deprecated mozL10n.get in Smart-Home → Migrate Smart-Home to L20n.js
Assignee: nobody → gandalf
Comment on attachment 8712327 [details] [review]
[gaia] zbraniecki:1243087-refactor-l10n-in-smart-home > mozilla-b2g:master

:tzhuang - can you review this for me?

We're deprecating l10n.js and migrating everything to L20n + new Intl API's for dates.

It also removes a nasty bug in updateClock that makes you register new event listener on each timeformat/time change (the code called mozL10n.ready on each change which added new callback each time)
Attachment #8712327 - Flags: review?(dwi2)
Comment on attachment 8712327 [details] [review]
[gaia] zbraniecki:1243087-refactor-l10n-in-smart-home > mozilla-b2g:master

This patch looks good to me. However I haven't involved in smart-home development for a while. I think Rex is more suitable for reviewing this. Thanks
Attachment #8712327 - Flags: review?(rexboy)
Attachment #8712327 - Flags: review?(dwi2)
Attachment #8712327 - Flags: feedback+
Comment on attachment 8712327 [details] [review]
[gaia] zbraniecki:1243087-refactor-l10n-in-smart-home > mozilla-b2g:master

r=me and sorry for the late review.
The code itself is good to me, and you can just land it. But let me explain some situation for TV-Gaia developers:
Until recently, developers of TV-Gaia still use B2G-Desktop for developing apps. B2G-Desktop's official support has ended at around October last year (that means it stopped at version 44), thus its support to the latest l20n API is just not enough. 
Developers are asked to transfer to Mulet and stop using B2G-Desktop. But until now, we found Mulet is somewhat unstable and inconvenient comparing with B2G-Desktop (See for example bug 1248907), so there are still developers use B2G-Desktop as their main developing tool, even though the version is out-of-date.

After landing this patch, developers are required to transfer to Mulet completely and get rid of B2G-Desktop and we need to push Mulet to fix their unstable bugs more actively.
Attachment #8712327 - Flags: review?(rexboy) → review+
Ok!

Landed: https://github.com/mozilla-b2g/gaia/commit/1e689f14896b95128ec4e189fbbf7f4d24496484
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Hey :gandalf, I'm getting an error when opening the TV in mulet after this patch:

TypeError: formatter.formatToParts is not a function home.js:803:19

Also, I can't skip the FTE focusing the OK button and pressing enter. Any idea? Thanks!
Flags: needinfo?(gandalf)
How new is your Gecko? I'm testing on Mulet from Feb 3rd and can't reproduce this error.
Flags: needinfo?(gandalf) → needinfo?(apastor)
Yeah, it was a Gecko version issue. Sorry!
Flags: needinfo?(apastor)
You need to log in before you can comment on or make changes to this bug.