[crash][top100] w/m9 at http://www.the-park.com

VERIFIED FIXED in M10

Status

()

P3
normal
VERIFIED FIXED
20 years ago
2 years ago

People

(Reporter: chofmann, Assigned: warrensomebody)

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

20 years ago
looks like we get a consistant crash at this top100 test url
using the m9 candidate builds from 8/24

Incident ID 12778865
ImageConsumer::SetKeepPumpingData
[d:\builds\seamonkey\mozilla\gfx\src\nsImageNetContextAsync.cpp, line 127]
ImageConsumer::OnStopRequest
[d:\builds\seamonkey\mozilla\gfx\src\nsImageNetContextAsync.cpp, line 383]
ImageConsumer::KeepPumpingStream
[d:\builds\seamonkey\mozilla\gfx\src\nsImageNetContextAsync.cpp, line 351]
TimerImpl::Fire
[d:\builds\seamonkey\mozilla\widget\timer\src\windows\nsTimer.cpp, line 310]
TimerImpl::ProcessTimeouts
[d:\builds\seamonkey\mozilla\widget\timer\src\windows\nsTimer.cpp, line 187]
FireTimeout [d:\builds\seamonkey\mozilla\widget\timer\src\windows\nsTimer.cpp,
line 103]
KERNEL32.DLL + 0x22db (0xbff722db)
FireTimeout [d:\builds\seamonkey\mozilla\widget\timer\src\windows\nsTimer.cpp,
line 83]
USER32.DLL + 0x4cbd (0xbff64cbd)
0xe48c0003
0xff1076ff

118 warren   1.23 #ifdef NECKO
119                 // nsIStreamObserver methods:
120 mccabe   1.39   NS_DECL_NSISTREAMOBSERVER
121
122 warren   1.23   // nsIStreamListener methods:
123 mccabe   1.39   NS_DECL_NSISTREAMLISTENER
124 warren   1.30
125                 void SetKeepPumpingData(nsIChannel* channel, nsISupports*
context) {
126                   NS_IF_RELEASE(mChannel);
127                   mChannel = channel;
128                   NS_ADDREF(mChannel);
129                   NS_IF_RELEASE(mUserContext);
130                   mUserContext = context;
131 gagan    1.36     if (mUserContext)
132                       NS_ADDREF(mUserContext);
133 warren   1.30   }
134 warren   1.23 #else
(Assignee)

Updated

20 years ago
Target Milestone: M10

Comment 1

20 years ago
Warren & Paul, this is probably a duplicate of 13090. (Also FYI, using the 1999
090208 builds, I can't reproduce this bug on Win32 or Mac OS.)

Updated

20 years ago
Status: NEW → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → FIXED

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 2

20 years ago
this looks fixed thanks eli

Comment 3

19 years ago
Bulk move of all Necko (to be deleted component) bugs to new Networking

component.
You need to log in before you can comment on or make changes to this bug.