CSS Sourcemap - A promise chain failed to handle a rejection

RESOLVED DUPLICATE of bug 1249888

Status

P3
normal
RESOLVED DUPLICATE of bug 1249888
3 years ago
2 months ago

People

(Reporter: xander, Unassigned)

Tracking

(Blocks: 1 bug)

45 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160124004010

Steps to reproduce:

Used 'Inspect Element' on a page with a sourcemapped CSS file where the styles.css.map file had a HTTP 403 returned.

You should be able to trigger this on the Crazy Domains website.


Actual results:

Mapped CSS line number does not display, files list in 'Style Editor' tab shows only a perpetual loading spinner. Clicking on source file line number link in 'Inspector' tab does nothing.

Browser console has multiple instances of this:
A promise chain failed to handle a rejection. Did you forget to '.catch', or did you forget to 'return'?
See https://developer.mozilla.org/Mozilla/JavaScript_code_modules/Promise.jsm/Promise

Date: Wed Jan 27 2016 09:07:57 GMT+0800 (W. Australia Standard Time)
Full Message: SyntaxError: JSON.parse: unexpected character at line 1 column 1 of the JSON data
Full Stack: SourceMapConsumer@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/shared/sourcemap/source-map.js:1281:20
StyleSheetActor<._fetchSourceMap/</map<@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/server/actors/stylesheets.js:753:21
Handler.prototype.process@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/Promise-backend.js:933:23
this.PromiseWalker.walkerLoop@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/Promise-backend.js:812:7
Promise*this.PromiseWalker.scheduleWalkerLoop@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/Promise-backend.js:743:11
this.PromiseWalker.schedulePromise@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/Promise-backend.js:775:7
this.PromiseWalker.completePromise@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/Promise-backend.js:710:7
mainThreadFetch/onResponse@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/shared/DevToolsUtils.js:642:7
NetUtil_asyncFetch/<.onStopRequest@resource://gre/modules/NetUtil.jsm:128:17


Expected results:

Files list should show loaded files (minified sources)
Source file line number link should switch to 'Style Editor' tab on correct file.

Updated

a year ago
Blocks: 1339970
Component: CSS Parsing and Computation → Developer Tools: Inspector
Priority: -- → P3
Product: Core → Firefox

Comment 1

11 months ago
I believe this was fixed by adding the try/catch to _fetchSourceMap back in bug 1249888.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1249888

Updated

2 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.