HTTP auth dialog for NSURLAuthenticationMethodNTLM auth method

VERIFIED FIXED

Status

()

Firefox for iOS
General
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: alex_johnson, Assigned: alex_johnson)

Tracking

unspecified
Other
iOS

Firefox Tracking Flags

(fxios4.0+)

Details

(URL)

Attachments

(1 attachment, 2 obsolete attachments)

(Assignee)

Description

2 years ago
My school's portal system uses a HTTP auth dialog for login, but it doesn't not open on Firefox for iOS. 

I am reporting this on behalf of my roommate who initially experienced this issue.  

It's an iPhone 5c running iOS 9.2.1.
On the URL above, on tap of `Login` (in the upper right), I am directed to a login form. I don't see an auth dialog?
(Assignee)

Comment 2

2 years ago
Created attachment 8712729 [details]
Screenshot from local network

(In reply to Aaron Train [:aaronmt] from comment #1)
> On the URL above, on tap of `Login` (in the upper right), I am directed to a
> login form. I don't see an auth dialog?

Ah.  Apparently, it uses HTTP auth when you try to login while connected to the local network.  It uses the form when logging in from somewhere else.
(Assignee)

Comment 3

2 years ago
Created attachment 8712732 [details]
Android device
(Assignee)

Comment 4

2 years ago
Created attachment 8712789 [details] [review]
Show HTTP auth dialog for NSURLAuthenticationMethodNTLM
Attachment #8712729 - Attachment is obsolete: true
Attachment #8712732 - Attachment is obsolete: true
Attachment #8712789 - Flags: review?(sleroux)
(Assignee)

Updated

2 years ago
Assignee: nobody → me
Status: NEW → ASSIGNED

Updated

2 years ago
tracking-fxios: --- → ?
(Assignee)

Updated

2 years ago
Summary: HTTP auth dialog doesn't open on https://mysau3.arbor.edu/ics/ → HTTP auth dialog for NSURLAuthenticationMethodNTLM auth method

Updated

2 years ago
Duplicate of this bug: 1243544
Test site URL attached
Comment on attachment 8712789 [details] [review]
Show HTTP auth dialog for NSURLAuthenticationMethodNTLM

Looks good - thanks for the patch Alex!
Attachment #8712789 - Flags: review?(sleroux) → review+
master 2ebf0a621626ad185e1208b9aa2e7e83337f726c
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
On build 2.0(4),the auth dialog is shown when visiting http://time.tecolote.com/
Status: RESOLVED → VERIFIED
tracking-fxios: ? → 4.0+
You need to log in before you can comment on or make changes to this bug.