JavaScript Console should use fixed width font

RESOLVED FIXED

Status

--
trivial
RESOLVED FIXED
17 years ago
9 years ago

People

(Reporter: rodd, Assigned: neil)

Tracking

({polish})

Trunk
polish

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
The JavaScript Console uses a variable with font.  This means that features like
the green arrow which underlines the point in a line with the JS fails is hard
to match up.

Switching to a fixed with font would make the green arrow appear under the point
in the line with the JS fails, just making the feature useful.

Updated

17 years ago
Severity: normal → enhancement
Keywords: helpwanted
(Assignee)

Comment 1

17 years ago
Created attachment 73456 [details] [diff] [review]
Proposed Patch

IIRC the problem is due to an error in attachment 26499 [details] [diff] [review] to bug 67647 - only the
classic skin was patched with the monospace style, the modern skin was
overlooked.
(Assignee)

Updated

17 years ago
Severity: enhancement → trivial
Keywords: helpwanted → patch, polish, review, ui
OS: Linux → All
Hardware: PC → All

Comment 2

17 years ago
i think this is one of the rare instances that justifies coding it in a  content style instead of in each theme.  [I'm saying this while wood is running here, and littlemozilla is running on my laptop.]  Just make sure that the node with the style also has an id and that a skin could win if it wanted to.

thoughts from skin authors?
Assignee: hewitt → neil

Comment 3

17 years ago
*** Bug 120680 has been marked as a duplicate of this bug. ***
Comment on attachment 73456 [details] [diff] [review]
Proposed Patch

r=bzbarsky; this is an incredible annoyance; could we get this in, please?

Comment 5

17 years ago
Comment on attachment 73456 [details] [diff] [review]
Proposed Patch

sr=hewitt
Attachment #73456 - Flags: superreview+
fix checked in on trunk.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Product: Core → SeaMonkey

Updated

9 years ago
Component: Error Console → Error Console
Product: SeaMonkey → Core Graveyard
You need to log in before you can comment on or make changes to this bug.