composer unsaved HTML source change crashes mozilla

VERIFIED FIXED in mozilla1.1alpha

Status

()

Core
Layout
P1
critical
VERIFIED FIXED
17 years ago
4 years ago

People

(Reporter: Laurie Flack, Assigned: rubydoo123)

Tracking

({crash, regression, testcase})

Trunk
mozilla1.1alpha
x86
Windows 98
crash, regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.8) Gecko/20020204
BuildID:    2002020406

composer unsaved HTML source change crashes mozilla

Reproducible: Always
Steps to Reproduce:
1.Edit HTML using Composer/HTML
2.Click on preview or normal - Mozilla crashes
3.

Comment 1

17 years ago
Tucson, can you verify this ? thanks.

Comment 2

17 years ago
I am unable to reproduce this with build 2002020803, or 2002020406.  Reporter, 
can you try this on a more recent build, and supply a more detailed test case 
if you are still able to reproduce? 

Comment 3

17 years ago
Laurie, please attach the test file here directly in the bug report.

Also provide more detailed steps to reproduce the problem.

thanks.
(Reporter)

Comment 4

17 years ago
Created attachment 68894 [details]
htm file demonstrates the problem

1. Edit file in Composer/HTML Source
2. Do not save it
3. Click on Preview

Then crash
MOZILLA caused an invalid page fault in
module GKCONTENT.DLL at 015f:6021d69e.
Registers:
EAX=00000000 CS=015f EIP=6021d69e EFLGS=00010202
EBX=0274a7ec SS=0167 ESP=0064da44 EBP=0064da68
ECX=00000000 DS=0167 ESI=00000004 FS=119f
EDX=00000008 ES=0167 EDI=00000000 GS=0000
Bytes at CS:EIP:
85 57 1c 74 08 89 7d f0 8b 7f 08 eb f3 8d 04 76 
Stack dump:
0276dfcc 0274a7ec 00000000 00000000 0274a7ec 02768118 00000000 00000000
00000000 0064db08 6021d3e2 00000008 0276081c 0064da88 0064dae8 00000000

Updated

17 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

17 years ago
Confirmed using trunk build 2002020803 on Win ME.

Talkback ID:  TB2790015Y

Comment 6

17 years ago
-->jfrancis

from talkback:
nsRuleNode::WalkRuleTree
[d:\builds\seamonkey\mozilla\content\base\src\nsRuleNode.cpp, line 1499]
nsRuleNode::GetContentData
[d:\builds\seamonkey\mozilla\content\base\src\nsRuleNode.cpp, line 1399]
nsRuleNode::GetStyleData
[d:\builds\seamonkey\mozilla\content\base\src\nsRuleNode.cpp, line 4667]
nsStyleContext::PeekStyleData
[d:\builds\seamonkey\mozilla\content\base\src\nsStyleContext.cpp, line 374]
nsStyleContext::CalcStyleDifference
[d:\builds\seamonkey\mozilla\content\base\src\nsStyleContext.cpp, line 677]
CaptureChange
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsFrameManager.cpp, line 1671]
FrameManager::ReResolveStyleContext
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsFrameManager.cpp, line 1777]
FrameManager::ReResolveStyleContext
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsFrameManager.cpp, line 1932]
FrameManager::ReResolveStyleContext
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsFrameManager.cpp, line 1932]
FrameManager::ReResolveStyleContext
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsFrameManager.cpp, line 1932]
FrameManager::ReResolveStyleContext
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsFrameManager.cpp, line 1932]
FrameManager::ReResolveStyleContext
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsFrameManager.cpp, line 1932]
FrameManager::ReResolveStyleContext
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsFrameManager.cpp, line 1932]
FrameManager::ComputeStyleChangeFor
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsFrameManager.cpp, line 2193]
PresShell::ReconstructStyleData
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5341]
PresShell::StyleSheetAdded
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5359]
nsDocument::InsertStyleSheetAt
[d:\builds\seamonkey\mozilla\content\base\src\nsDocument.cpp, line 1417]
CSSLoaderImpl::InsertSheetInDoc
[d:\builds\seamonkey\mozilla\content\html\style\src\nsCSSLoader.cpp, line 1196]
CSSLoaderImpl::LoadStyleLink
[d:\builds\seamonkey\mozilla\content\html\style\src\nsCSSLoader.cpp, line 1466]
nsStyleLinkElement::UpdateStyleSheet
[d:\builds\seamonkey\mozilla\content\base\src\nsStyleLinkElement.cpp, line 356]
nsHTMLLinkElement::SetDocument
[d:\builds\seamonkey\mozilla\content\html\content\src\nsHTMLLinkElement.cpp,
line 106]
nsGenericContainerElement::InsertChildAt
[d:\builds\seamonkey\mozilla\content\base\src\nsGenericElement.cpp, line 3454]
nsGenericElement::doInsertBefore
[d:\builds\seamonkey\mozilla\content\base\src\nsGenericElement.cpp, line 2292]
nsHTMLDelElement::InsertBefore
[d:\builds\seamonkey\mozilla\content\html\content\src\nsHTMLDelElement.cpp]
InsertElementTxn::DoTransaction
[d:\builds\seamonkey\mozilla\editor\libeditor\base\InsertElementTxn.cpp, line 115]
nsTransactionItem::DoTransaction
[d:\builds\seamonkey\mozilla\editor\txmgr\src\nsTransactionItem.cpp, line 183]
nsTransactionManager::BeginTransaction
[d:\builds\seamonkey\mozilla\editor\txmgr\src\nsTransactionManager.cpp, line 1078]
nsTransactionManager::DoTransaction
[d:\builds\seamonkey\mozilla\editor\txmgr\src\nsTransactionManager.cpp, line 140]
nsEditor::Do [d:\builds\seamonkey\mozilla\editor\libeditor\base\nsEditor.cpp,
line 494]
nsEditor::InsertNode
[d:\builds\seamonkey\mozilla\editor\libeditor\base\nsEditor.cpp, line 1152]
nsHTMLEditor::ReplaceHeadContentsWithHTML
[d:\builds\seamonkey\mozilla\editor\libeditor\html\nsHTMLEditor.cpp, line 1646]
nsHTMLEditor::RebuildDocumentFromSource
[d:\builds\seamonkey\mozilla\editor\libeditor\html\nsHTMLEditor.cpp, line 1708]
nsEditorShell::RebuildDocumentFromSource
[d:\builds\seamonkey\mozilla\editor\composer\src\nsEditorShell.cpp, line 2366]
XPTC_InvokeByIndex
[d:\builds\seamonkey\mozilla\xpcom\reflect\xptcall\src\md\win32\xptcinvoke.cpp,
line 106]
XPCWrappedNative::CallMethod
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednative.cpp, line 2000]
XPC_WN_CallMethod
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednativejsops.cpp,
line 1267]
js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 834]
js_Interpret [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2803]
js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 850]
js_InternalInvoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 925]
JS_CallFunctionValue [d:\builds\seamonkey\mozilla\js\src\jsapi.c, line 3407]
nsJSContext::CallEventHandler
[d:\builds\seamonkey\mozilla\dom\src\base\nsJSEnvironment.cpp, line 1019]
nsJSEventListener::HandleEvent
[d:\builds\seamonkey\mozilla\dom\src\events\nsJSEventListener.cpp, line 182]
nsEventListenerManager::HandleEventSubType
[d:\builds\seamonkey\mozilla\content\events\src\nsEventListenerManager.cpp, line
1206]
nsEventListenerManager::HandleEvent
[d:\builds\seamonkey\mozilla\content\events\src\nsEventListenerManager.cpp, line
2198]
nsXULElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 3383]
PresShell::HandleDOMEventWithTarget
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 6050]
nsButtonBoxFrame::MouseClicked
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsButtonBoxFrame.cpp, line 195]
nsButtonBoxFrame::HandleEvent
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsButtonBoxFrame.cpp, line 142]
PresShell::HandleEventInternal
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 6019]
PresShell::HandleEventWithTarget
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5970]
nsEventStateManager::CheckForAndDispatchClick
[d:\builds\seamonkey\mozilla\content\events\src\nsEventStateManager.cpp, line 2464]
nsEventStateManager::PostHandleEvent
[d:\builds\seamonkey\mozilla\content\events\src\nsEventStateManager.cpp, line 1546]
PresShell::HandleEventInternal
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 6023]
PresShell::HandleEvent
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5925]
nsView::HandleEvent [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 390]
nsViewManager::DispatchEvent
[d:\builds\seamonkey\mozilla\view\src\nsViewManager.cpp, line 1900]
HandleEvent [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 83]
nsWindow::DispatchEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 854]
nsWindow::DispatchWindowEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 871]
nsWindow::DispatchMouseEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 4537]
ChildWindow::DispatchMouseEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 4787]
nsWindow::ProcessMessage
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 3463]
nsWindow::WindowProc
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 1116] 
Assignee: syd → jfrancis
Component: Editor: Composer → Editor: Core
Keywords: crash, regression
Whiteboard: EDITORBASE

Comment 7

17 years ago
This crash is in layout.  reassigning...
Assignee: jfrancis → attinasi
Component: Editor: Core → Layout
QA Contact: sujay → petersen

Comment 8

17 years ago
Can someone come up with a reduced testcase that still causes the crash?
Keywords: nsbeta1+
(Reporter)

Comment 9

17 years ago
Created attachment 69073 [details]
small file to demonstrate problem - must have main.css as well
(Reporter)

Comment 10

17 years ago
Created attachment 69074 [details]
use with cw.htm to demonstrate this problem

Updated

17 years ago
Target Milestone: --- → mozilla1.0

Comment 11

17 years ago
I can't get to reproduce under the OS X Feb 11th (2002-02-11-08) or under
Windows ME Feb 12th(2002-02-12-03) Builds. Sujay, can you reproduce ?

Comment 12

17 years ago
Tucson and I can reproduce on Windows.

Peterse, please try on Win.

Comment 13

17 years ago
Hmmm.. Based on the steps (and test case) provided, I can't reproduce on the
latest trunk build (2002-02-12-03) under Windows ME. Sample HTML and css files
are saved locally on drive. I open html file in Navigator, then select Edit Page
from File menu.Composer opens. I then click on either Preview or Normal tabs. No
crash occurs (at least for me).

Comment 14

17 years ago
I am able to reproduce this problem on the 2002021203 trunk build on Win ME.  
But I am not saving the file locally first (which could be part of the reason 
why you are not able to reproduce this).  

All I do is:
1. Load the testcase in Navigator from the link in comment 4
2. Click on File - Edit to edit it in Composer
3. Change to HTML source view and make some changes
4. Switch to Preview view
5. Crash

Comment 15

17 years ago
Thanks... I can reproduce it now.

**********

Date/Time:  2002-02-12 15:13:56 -0800
OS Version: 10.1.2 (Build 5P48)
Host:       localhost

Command:    Mozilla
PID:        732

Exception:  EXC_BAD_ACCESS (0x0001)
Codes:      KERN_PROTECTION_FAILURE (0x0002) at 0x00000014

Thread 0 Crashed:
 #0   0x0226208c in nsRuleNode::GetStyleData(nsStyleStructID, nsIStyleContext *)
 #1   0x021d2598 in 0x21d2598
 #2   0x02aa5768 in CaptureChange(nsIStyleContext *, nsIStyleContext *, nsIFrame *)
 #3   0x02aa5af0 in 0x2aa5af0
 #4   0x02aa60e4 in ReResolveStyleContext__12FrameManagerFP14nsIPresContextP8nsIFr
 #5   0x02aa60e4 in ReResolveStyleContext__12FrameManagerFP14nsIPresContextP8nsIFr
 #6   0x02aa60e4 in ReResolveStyleContext__12FrameManagerFP14nsIPresContextP8nsIFr
 #7   0x02aa60e4 in ReResolveStyleContext__12FrameManagerFP14nsIPresContextP8nsIFr
 #8   0x02aa60e4 in ReResolveStyleContext__12FrameManagerFP14nsIPresContextP8nsIFr
 #9   0x02aa60e4 in ReResolveStyleContext__12FrameManagerFP14nsIPresContextP8nsIFr
 #10  0x02aa6320 in ComputeStyleChangeFor__12FrameManagerFP14nsIPresContextP8nsIFr
 #11  0x02992a44 in PresShell::ReconstructStyleData(int)
 #12  0x02992bfc in PresShell::StyleSheetAdded(nsIDocument *, nsIStyleSheet *)
 #13  0x01f7f290 in nsDocument::InsertStyleSheetAt(nsIStyleSheet *, int, int)
 #14  0x02151774 in InsertSheetInDoc__13CSSLoaderImplFP16nsICSSStyleSheetiP10nsICo
 #15  0x021526c8 in LoadStyleLink__13CSSLoaderImplFP10nsIContentP6nsIURIRC8nsStrin
 #16  0x02252544 in nsStyleLinkElement::UpdateStyleSheet(int, nsIDocument *, int)
 #17  0x0208f9e0 in nsHTMLLinkElement::SetDocument(nsIDocument *, int, int)
 #18  0x0202f51c in nsGenericHTMLContainerElement::InsertChildAt(nsIContent *,
int, int)
 #19  0x020fe618 in nsGenericElement::doInsertBefore(nsIDOMNode *, nsIDOMNode *,  *)
 #20  0x02067860 in nsHTMLHeadElement::InsertBefore(nsIDOMNode *, nsIDOMNode *,  **)
 #21  0x036e2a14 in InsertElementTxn::DoTransaction(void)
 #22  0x037fd1c4 in nsTransactionItem::DoTransaction(void)
 #23  0x037fc650 in nsTransactionManager::BeginTransaction(nsITransaction *)
 #24  0x037f9d20 in nsTransactionManager::DoTransaction(nsITransaction *)
 #25  0x036cb0f8 in nsEditor::Do(nsITransaction *)
 #26  0x036cdc8c in nsEditor::InsertNode(nsIDOMNode *, nsIDOMNode *, int)
 #27  0x036ebdb8 in nsHTMLEditor::ReplaceHeadContentsWithHTML(nsAString const &)
 #28  0x036ec7a4 in 0x36ec7a4
 #29  0x04f3e558 in nsEditorShell::RebuildDocumentFromSource(wchar_t const *)
 #30  0x005c418c in XPTC_InvokeByIndex
 #31  0x005c4080 in XPTC_InvokeByIndex
 #32  0x01b4258c in 0x1b4258c
 #33  0x01b4898c in XPC_WN_CallMethod(JSContext *, JSObject *, unsigned int,
long *, long *)
 #34  0x01ac455c in js_Invoke
 #35  0x01acc620 in 0x1acc620
 #36  0x01ac45b4 in js_Invoke
 #37  0x01ac4800 in js_InternalInvoke
 #38  0x01aa5b3c in JS_CallFunctionValue
 #39  0x0271c0f0 in nsJSContext::CallEventHandler(void *, void *, unsigned int,
void *, int *, int)
 #40  0x027396d4 in nsJSEventListener::HandleEvent(nsIDOMEvent *)
 #41  0x020082b0 in HandleEventSubType__22nsEventListenerManagerFP16nsListenerStru
 #42  0x0200a8f8 in HandleEvent__22nsEventListenerManagerFP14nsIPresConte
 #43  0x02228924 in HandleDOMEvent__12nsXULElementFP14nsIPresContextP7nsEventPP11n
 #44  0x02994730 in HandleDOMEventWithTarget__9PresShellFP10nsIContentP7nsEventP13
 #45  0x02ac2748 in MouseClicked__16nsButtonBoxFrameFP14nsIPresContextP10nsGUIEven
 #46  0x02ac2368 in nsButtonBoxFrame::HandleEvent(nsIPresContext *, nsGUIEvent *)
 #47  0x029945bc in HandleEventInternal__9PresShellFP7nsEventP7nsIViewUiP13nsEvent
 #48  0x02994344 in HandleEventWithTarget__9PresShellFP7nsEventP8nsIFrameP10nsICon
 #49  0x02014230 in CheckForAndDispatchClick__19nsEventStateManagerFP14nsIPresCont
 #50  0x02012188 in 0x2012188
 #51  0x02994600 in HandleEventInternal__9PresShellFP7nsEventP7nsIViewUiP13nsEvent
 #52  0x02994258 in PresShell::HandleEvent(nsIView *, nsGUIEvent *, nsEventStatus *)
 #53  0x02c1867c in nsViewManager::HandleEvent(nsView *, nsGUIEvent *, int)
 #54  0x02c0e4fc in nsView::HandleEvent(nsViewManager *, nsGUIEvent *, int)
 #55  0x02c17a98 in 0x2c17a98
 #56  0x02c0dba8 in HandleEvent(nsGUIEvent *)
 #57  0x01dbdb14 in nsWindow::DispatchEvent(nsGUIEvent *, nsEventStatus &)
 #58  0x01dbdbec in nsWindow::DispatchWindowEvent(nsGUIEvent &)
 #59  0x01dbdd38 in nsWindow::DispatchMouseEvent(nsMouseEvent &)
 #60  0x01dcfb38 in nsMacEventHandler::HandleMouseUpEvent(EventRecord &)
 #61  0x01dcdeb4 in nsMacEventHandler::HandleOSEvent(EventRecord &)
 #62  0x01dcce04 in nsMacWindow::DispatchEvent(void *, int *)
 #63  0x01dd4970 in DispatchOSEventToRaptor__16nsMacMessagePumpFR11EventRecordP15O
 #64  0x01dd4500 in nsMacMessagePump::DoMouseUp(EventRecord &)
 #65  0x01dd384c in nsMacMessagePump::DispatchEvent(int, EventRecord *)
 #66  0x01dd3510 in nsMacMessagePump::DoMessagePump(void)
 #67  0x01dd2e8c in nsAppShell::Run(void)
 #68  0x01d8fd3c in nsAppShellService::Run(void)
 #69  0x004cbba4 in main1(int, char **, nsISupports *)
 #70  0x004cc67c in main

Thread 1:
 #0   0x7000497c in syscall
 #1   0x70557600 in BSD_waitevent
 #2   0x70554b80 in CarbonSelectThreadFunc
 #3   0x7002054c in _pthread_body

Thread 2:
 #0   0x7003f4c8 in semaphore_wait_signal_trap
 #1   0x7003f2c8 in _pthread_cond_wait
 #2   0x705593ec in CarbonOperationThreadFunc
 #3   0x7002054c in _pthread_body

Thread 3:
 #0   0x70044cf8 in semaphore_timedwait_signal_trap
 #1   0x70044cd8 in semaphore_timedwait_signal
 #2   0x70283ea4 in TSWaitOnConditionTimedRelative
 #3   0x7027d748 in TSWaitOnSemaphoreCommon
 #4   0x702c2078 in TimerThread
 #5   0x7002054c in _pthread_body

Thread 4:
 #0   0x7003f4c8 in semaphore_wait_signal_trap
 #1   0x7003f2c8 in _pthread_cond_wait
 #2   0x70250ab0 in TSWaitOnCondition
 #3   0x7027d730 in TSWaitOnSemaphoreCommon
 #4   0x70243d14 in AsyncFileThread
 #5   0x7002054c in _pthread_body

Thread 5:
 #0   0x7003f4c8 in semaphore_wait_signal_trap
 #1   0x7003f2c8 in _pthread_cond_wait
 #2   0x7055b884 in CarbonInetOperThreadFunc
 #3   0x7002054c in _pthread_body

Thread 6:
 #0   0x70000978 in mach_msg_overwrite_trap
 #1   0x70005a04 in mach_msg
 #2   0x7017bf98 in __CFRunLoopRun
 #3   0x701b7100 in CFRunLoopRunSpecific
 #4   0x7017b8e0 in CFRunLoopRunInMode
 #5   0x7061be08 in
XIOAudioDeviceManager::NotificationThread(XIOAudioDeviceManager *)
 #6   0x706141c0 in CAPThread::Entry(CAPThread *)
 #7   0x7002054c in _pthread_body

Thread 7:
 #0   0x70000978 in mach_msg_overwrite_trap
 #1   0x70005a04 in mach_msg
 #2   0x70026a2c in _pthread_become_available
 #3   0x70026724 in pthread_exit
 #4   0x70020550 in _pthread_body

PPC Thread State:
  srr0: 0x0226208c srr1: 0x0000f030                vrsave: 0x00000000
   xer: 0x20000008   lr: 0x021d2598  ctr: 0x021d1380   mq: 0x00000000
    r0: 0x00000000   r1: 0xbfffbdb0   r2: 0x02344000   r3: 0x00000000
    r4: 0x00000014   r5: 0x056bb030   r6: 0x023cbe28   r7: 0x023cbdc8
    r8: 0x023cbe28   r9: 0x00000060  r10: 0x00000001  r11: 0x02295cc8
   r12: 0x023588dc  r13: 0x048544f0  r14: 0x056bbb4c  r15: 0x00000036
   r16: 0x0562a590  r17: 0x02bf1d08  r18: 0x00000000  r19: 0xbfffbfcc
   r20: 0x00000000  r21: 0x0562bc10  r22: 0xffffffff  r23: 0xbfffc4bc
   r24: 0x00000000  r25: 0x056bbb4c  r26: 0x04f78240  r27: 0x00000000
   r28: 0x023cbdc8  r29: 0x05632998  r30: 0x0575757c  r31: 0x00000000

**********

Updated

17 years ago
Keywords: testcase

Comment 16

17 years ago
I can reproduce this - P1

Looks like there is a problem when the link'd stylesheet is added - causing the
rule tree to be garbage.  I'll investigate this further.
Status: NEW → ASSIGNED
Priority: -- → P1

Comment 17

16 years ago
David Baron's patch for bug 118014 solves most of this crash.  With that patch,
we don't crash until we close the composer window ;)

Comment 18

16 years ago
Not created by our composer, so EDITORBASE- and nsbeta1- 
Keywords: nsbeta1+ → nsbeta1-
Whiteboard: EDITORBASE → EDITORBASE-

Comment 19

16 years ago
Please clarify why this is no longer EDITORBASE or NSBETA1 approved. I do not
uderstand the statement:

'Not created by our composer, so EDITORBASE- and nsbeta1-'

This still crashes when the window is closed, with this stack:

ns_if_addref(nsIPresContext * 0x00000001) line 122 + 9 bytes
nsRuleNode::GetPresContext(nsIPresContext * * 0x0012eb1c) line 616 + 19 bytes
nsStyleContext::Destroy() line 1277 + 35 bytes
nsStyleContext::Release(nsStyleContext * const 0x04b2504c) line 186 + 134 bytes
nsStyleContext::~nsStyleContext() line 174 + 18 bytes
nsStyleContext::`scalar deleting destructor'(unsigned int 0) + 15 bytes
nsStyleContext::Destroy() line 1284
nsStyleContext::Release(nsStyleContext * const 0x04b29d2c) line 186 + 134 bytes
nsStyleContext::~nsStyleContext() line 174 + 18 bytes
nsStyleContext::`scalar deleting destructor'(unsigned int 0) + 15 bytes
nsStyleContext::Destroy() line 1284
nsStyleContext::Release(nsStyleContext * const 0x04b24328) line 186 + 134 bytes
nsFrame::~nsFrame() line 287 + 27 bytes
nsSplittableFrame::~nsSplittableFrame() + 15 bytes
nsContainerFrame::~nsContainerFrame() line 79 + 19 bytes
nsHTMLContainerFrame::~nsHTMLContainerFrame() + 15 bytes
nsInlineFrame::~nsInlineFrame() + 15 bytes
nsInlineFrame::`scalar deleting destructor'(unsigned int 1) + 15 bytes
nsFrame::Destroy(nsFrame * const 0x04b248dc, nsIPresContext * 0x04b6cb58) line
466 + 34 bytes
nsContainerFrame::Destroy(nsContainerFrame * const 0x04b248dc, nsIPresContext *
0x04b6cb58) line 142
nsLineBox::DeleteLineList(nsIPresContext * 0x04b6cb58, nsLineList & {...}) line 312
nsBlockFrame::Destroy(nsBlockFrame * const 0x04b2439c, nsIPresContext *
0x04b6cb58) line 328 + 16 bytes
nsLineBox::DeleteLineList(nsIPresContext * 0x04b6cb58, nsLineList & {...}) line 312
nsBlockFrame::Destroy(nsBlockFrame * const 0x04b21108, nsIPresContext *
0x04b6cb58) line 328 + 16 bytes
nsAreaFrame::Destroy(nsAreaFrame * const 0x04b21108, nsIPresContext *
0x04b6cb58) line 169
nsFrameList::DestroyFrames(nsIPresContext * 0x04b6cb58) line 131
nsContainerFrame::Destroy(nsContainerFrame * const 0x04bcc1c8, nsIPresContext *
0x04b6cb58) line 141
nsFrameList::DestroyFrames(nsIPresContext * 0x04b6cb58) line 131
nsContainerFrame::Destroy(nsContainerFrame * const 0x04bcc660, nsIPresContext *
0x04b6cb58) line 141
nsBoxFrame::Destroy(nsBoxFrame * const 0x04bcc660, nsIPresContext * 0x04b6cb58)
line 1240 + 13 bytes
nsFrameList::DestroyFrames(nsIPresContext * 0x04b6cb58) line 131
nsContainerFrame::Destroy(nsContainerFrame * const 0x04bcc468, nsIPresContext *
0x04b6cb58) line 141
nsBoxFrame::Destroy(nsBoxFrame * const 0x04bcc468, nsIPresContext * 0x04b6cb58)
line 1240 + 13 bytes
nsGfxScrollFrame::Destroy(nsGfxScrollFrame * const 0x04bcc468, nsIPresContext *
0x04b6cb58) line 465
nsFrameList::DestroyFrames(nsIPresContext * 0x04b6cb58) line 131
nsContainerFrame::Destroy(nsContainerFrame * const 0x04bcc18c, nsIPresContext *
0x04b6cb58) line 141
ViewportFrame::Destroy(ViewportFrame * const 0x04bcc18c, nsIPresContext *
0x04b6cb58) line 157
FrameManager::Destroy(FrameManager * const 0x04b3b078) line 515
PresShell::Destroy(PresShell * const 0x04b3a170) line 1719
DocumentViewerImpl::Destroy(DocumentViewerImpl * const 0x04b7d230) line 1454
nsDocShell::Destroy(nsDocShell * const 0x04aaa16c) line 2614
nsWebShell::Destroy(nsWebShell * const 0x04aaa16c) line 1248
nsHTMLFrameInnerFrame::~nsHTMLFrameInnerFrame() line 675
nsHTMLFrameInnerFrame::`scalar deleting destructor'(unsigned int 1) + 15 bytes
nsFrame::Destroy(nsFrame * const 0x04aa817c, nsIPresContext * 0x03b2c1c0) line
466 + 34 bytes
nsFrameList::DestroyFrames(nsIPresContext * 0x03b2c1c0) line 131
nsContainerFrame::Destroy(nsContainerFrame * const 0x04aa80bc, nsIPresContext *
0x03b2c1c0) line 141
nsFrameList::DestroyFrames(nsIPresContext * 0x03b2c1c0) line 131
nsContainerFrame::Destroy(nsContainerFrame * const 0x04aa483c, nsIPresContext *
0x03b2c1c0) line 141
nsBoxFrame::Destroy(nsBoxFrame * const 0x04aa483c, nsIPresContext * 0x03b2c1c0)
line 1240 + 13 bytes
nsFrameList::DestroyFrames(nsIPresContext * 0x03b2c1c0) line 131
nsContainerFrame::Destroy(nsContainerFrame * const 0x04aa4750, nsIPresContext *
0x03b2c1c0) line 141
nsBoxFrame::Destroy(nsBoxFrame * const 0x04aa4750, nsIPresContext * 0x03b2c1c0)
line 1240 + 13 bytes
nsFrameList::DestroyFrames(nsIPresContext * 0x03b2c1c0) line 131
nsContainerFrame::Destroy(nsContainerFrame * const 0x04aa45e0, nsIPresContext *
0x03b2c1c0) line 141
nsBoxFrame::Destroy(nsBoxFrame * const 0x04aa45e0, nsIPresContext * 0x03b2c1c0)
line 1240 + 13 bytes
nsFrameList::DestroyFrames(nsIPresContext * 0x03b2c1c0) line 131
nsContainerFrame::Destroy(nsContainerFrame * const 0x04aa428c, nsIPresContext *
0x03b2c1c0) line 141
nsBoxFrame::Destroy(nsBoxFrame * const 0x04aa428c, nsIPresContext * 0x03b2c1c0)
line 1240 + 13 bytes
nsFrameList::DestroyFrames(nsIPresContext * 0x03b2c1c0) line 131
nsContainerFrame::Destroy(nsContainerFrame * const 0x04970bc0, nsIPresContext *
0x03b2c1c0) line 141
nsBoxFrame::Destroy(nsBoxFrame * const 0x04970bc0, nsIPresContext * 0x03b2c1c0)
line 1240 + 13 bytes
nsFrameList::DestroyFrames(nsIPresContext * 0x03b2c1c0) line 131
nsContainerFrame::Destroy(nsContainerFrame * const 0x049709d4, nsIPresContext *
0x03b2c1c0) line 141
nsBoxFrame::Destroy(nsBoxFrame * const 0x049709d4, nsIPresContext * 0x03b2c1c0)
line 1240 + 13 bytes
nsFrameList::DestroyFrames(nsIPresContext * 0x03b2c1c0) line 131
nsContainerFrame::Destroy(nsContainerFrame * const 0x04970998, nsIPresContext *
0x03b2c1c0) line 141
ViewportFrame::Destroy(ViewportFrame * const 0x04970998, nsIPresContext *
0x03b2c1c0) line 157
FrameManager::Destroy(FrameManager * const 0x03b2e480) line 515
PresShell::Destroy(PresShell * const 0x03b2d5e0) line 1719
DocumentViewerImpl::Destroy(DocumentViewerImpl * const 0x03e96190) line 1454
nsDocShell::Destroy(nsDocShell * const 0x03b1ef34) line 2614
nsWebShell::Destroy(nsWebShell * const 0x03b1ef34) line 1248
nsXULWindow::Destroy(nsXULWindow * const 0x03b20f24) line 421
nsWebShellWindow::Destroy(nsWebShellWindow * const 0x03b20f24) line 1739 + 9 bytes
nsWebShellWindow::Close(nsWebShellWindow * const 0x03b20f7c) line 388
nsWebShellWindow::HandleEvent(nsGUIEvent * 0x0012f5f0) line 466
nsWindow::DispatchEvent(nsWindow * const 0x03b210d4, nsGUIEvent * 0x0012f5f0,
nsEventStatus & nsEventStatus_eIgnore) line 865 + 10 bytes
nsWindow::DispatchWindowEvent(nsGUIEvent * 0x0012f5f0) line 886
nsWindow::DispatchStandardEvent(unsigned int 101) line 906 + 15 bytes
nsWindow::ProcessMessage(unsigned int 16, unsigned int 0, long 0, long *
0x0012f9b8) line 3388
nsWindow::WindowProc(HWND__ * 0x00550e22, unsigned int 16, unsigned int 0, long
0) line 1130 + 27 bytes
USER32! 77e12e98()

Comment 20

16 years ago
renominate for attinasi so his questions will be noticed and answered
Keywords: nsbeta1- → nsbeta1
Whiteboard: EDITORBASE- → EDITORBASE
EDITORBASE applies only to basic editing of content that was created by
composer. The content in this bug was created by some other mechanism (Microsoft
FrontPage Express 2.0) Since composer was not used to create the content it is
not a EDITORBASE candidate. 
Keywords: nsbeta1 → nsbeta1-
Whiteboard: EDITORBASE → EDITORBASE-

Comment 22

16 years ago
milestone shift...
Target Milestone: mozilla1.0 → mozilla1.1alpha

Comment 23

16 years ago
this seems to work now, please retest
Assignee: attinasi → beppe
Status: ASSIGNED → NEW
Keywords: qawanted
QA Contact: petersen → beppe
Whiteboard: EDITORBASE-
(Assignee)

Comment 24

15 years ago
performed various edits in different modes (Normal, HTML Tags, HTML Source) and
selected Preview numerous times. Selected undo/redo, etc. I could not initiate a
cash. Marking Fixed/Verified
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
(Assignee)

Comment 25

15 years ago
verified
Status: RESOLVED → VERIFIED
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.