kilobyte should be abbreviated "KB", not "K"

RESOLVED FIXED in mozilla1.4beta

Status

--
minor
RESOLVED FIXED
17 years ago
7 years ago

People

(Reporter: michael.wardle, Assigned: mikel)

Tracking

({polish})

Trunk
mozilla1.4beta
polish

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
When subscribing to newsgroups, mailnews first downloads the list of newsgroups.
 During downloading, status text is displayed such as "200K read at 2.4K/sec". 
This is really bad notation.

If we are going to follow standards, the text should read
"200 KiB read at 2.4 KiB/s" (see bug 65710).

If not, we should at least adopt what is most common in recent times, which
would be "200 KB read at 2.4 KB/s".

Comment 1

17 years ago

*** This bug has been marked as a duplicate of 65710 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

17 years ago
This is not a duplicate.  Everywhere else in the app, kilobyte is abbreviated
"KB".  In this part of mailnews it's still "K", which is wrong.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Reporter)

Comment 3

17 years ago
If anything, it's closest to bug 64179, which changed "K" to "KB" and was fixed.
 This bug was related to the installer, tho.  This is the same thing happening
in mailnews, and should be fixed in the same way.
Since 106618 decided the SI notation was pathetic, rephrasing the title to not
include the SI alternative, lest this bug get misunderstood.
Summary: kilobyte should be abbreviated "KiB" (SI) or "KB" (common use) not "K" → kilobyte should be abbreviated "KB", not "K"

Comment 5

17 years ago
See also bug 65710 for my comments about proper labeling of kilobytes ("kB").
(Assignee)

Comment 6

17 years ago
Created attachment 70058 [details] [diff] [review]
diff of chrome properties files, changes "K/sec" to "KB/sec"

A one-line change to change an occurence of "K" to "KB" in the news properties
file.

I think that "sec" should actually be "s" and there should be a space between
the number and the unit, but I have made neither change to retain consistency
with other such text strings within Mozilla.
(Assignee)

Comment 7

17 years ago
Adding my home account to the CC list.

Technically this is applicable to all OSs (change was made to generic en-US
locale, not platform-dependent), so if somebody could please change OS->All...
(Assignee)

Comment 8

17 years ago
What do I have to do to get this checked in?

Comment 9

17 years ago
Confirming bug. Patch exists. Nominating for Mozilla1.0. This is a minor change,
and it helps Mozilla look good.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: mozilla1.0

Comment 10

16 years ago
Trying to help get this patch in.
Keywords: polish, review
OS: Windows 2000 → All
Hardware: PC → All

Updated

16 years ago
Attachment #70058 - Flags: review?(sspitzer)

Updated

16 years ago
Attachment #70058 - Flags: superreview?(sspitzer)
Attachment #70058 - Flags: review?(sspitzer)
Attachment #70058 - Flags: review+
Comment on attachment 70058 [details] [diff] [review]
diff of chrome properties files, changes "K/sec" to "KB/sec"

sr=sspitzer, since this is consistent.

C:\trees\trunk\mozilla\embedding\components\ui\progressDlg\locale\en-US\nsProgr
essDialog.dtd(90):    #3 will be replaced by the download rate (in KB per
second) -->
C:\trees\trunk\mozilla\embedding\components\ui\progressDlg\locale\en-US\nsProgr
essDialog.dtd(91):<!ENTITY progressMsg "#1KB of #2KB (at #3KB/sec)">
C:\trees\trunk\mozilla\mailnews\base\prefs\resources\locale\en-US\am-offline.dt
d(8):<!ENTITY kb.label "KB">
C:\trees\trunk\mozilla\mailnews\base\prefs\resources\locale\en-US\pref-diskspac
e.dtd(33):<!ENTITY kb.label			  "KB">
C:\trees\trunk\mozilla\mailnews\base\resources\locale\en-US\messenger.propertie
s(278):quotaUsedFree=%S of %S KB used
C:\trees\trunk\mozilla\xpfe\browser\resources\locale\en-US\metadata.properties(
9):imageSize=%S KB (%S bytes)
C:\trees\trunk\mozilla\xpfe\browser\resources\locale\en-US\pageInfo.properties(
70):generalSize=%S KB (%S bytes)
C:\trees\trunk\mozilla\xpfe\components\download-manager\resources\locale\en-US\
downloadmanager.dtd(26):<!ENTITY progressMsgNoRate "#1KB of #2KB">
C:\trees\trunk\mozilla\xpfe\components\download-manager\resources\locale\en-US\
downloadmanager.dtd(27):<!ENTITY rateMsg "#1KB/sec">
C:\trees\trunk\mozilla\xpfe\components\download-manager\resources\locale\en-US\
downloadmanager.properties(1):transferred=%1SKB of %2SKB
C:\trees\trunk\mozilla\xpfe\components\prefwindow\resources\locale\en-US\pref-c
ache.dtd(9):<!ENTITY  kbytes			    "KB">
C:\trees\trunk\mozilla\xpfe\components\prefwindow\resources\locale\en-US\pref-o
ffline.dtd(25):<!ENTITY kb.label "KB">
C:\trees\trunk\mozilla\xpfe\components\xfer\resources\locale\en-US\downloadProg
ress.dtd(28):<!ENTITY progressMsg "#1KB of #2KB (at #3KB/sec)">

neil can you land this?
Attachment #70058 - Flags: superreview?(sspitzer) → superreview+
re-assign, for proper credit.
Assignee: sspitzer → michael
Target Milestone: --- → mozilla1.4beta

Comment 13

16 years ago
Fix checked in.
Status: NEW → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → FIXED

Comment 14

16 years ago
The fix for this bug is incorrect (as is the summary line.)  The correct
capitalization for kilo in all international standards is that the k is in
lowercase, and has been for ages.  Other uses are incorrect, and look odd to
people familiar with the proper notation.  I'm not advocating the use of
kibibytes, but kB is closer to correct.  See: 
http://physics.nist.gov/cuu/Units/prefixes.html

Please re-open.

Comment 15

16 years ago
Bug 65710 is for changing from KB to the precisely defined SI units for amounts
of data. That bug is probably where further discussion should take place.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.