If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

manual download page for Firefox 44 gives Firefox 43.0.1 instead

RESOLVED INVALID

Status

www.mozilla.org
General
RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: mcdavis941 (sporadically reading bugmail), Unassigned)

Tracking

Production

Firefox Tracking Flags

(Not tracked)

Details

The issue is that the manual download page for Firefox 44 is taking me to an .exe file that looks to be for Firefox 43.

The manual download page: https://www.mozilla.org/en-US/firefox/all/

Clicking on the en-US MSWindows download offers a file called "Firefox Setup 43.0.1.exe".  Firefox 44 was released yesterday.

Whether it's the wrong file or the right file with the wrong name, that's confusing.

I'm on MSWindows Vista.
I believe this is intentional for Windows Vista users. See Bug 1234882 for more detail
(In reply to Alex Gibson [:agibson] from comment #1)
> I believe this is intentional for Windows Vista users. See Bug 1234882 for
> more detail

That's does look likely after some reading.

> Whether it's the wrong file or the right file with the wrong name

Or working as intended.
Resolving this bug as invalid as per bug 1234882
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.