Pasting an invalid URL breaks the Downloads View in the Library (downloads are displayed as history items)

VERIFIED FIXED in Firefox 50

Status

()

defect
VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: arni2033, Assigned: Paolo)

Tracking

({regression})

Trunk
Firefox 51
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox47 wontfix, firefox48 wontfix, firefox49 fix-optional, firefox50 verified, firefox51 verified)

Details

Attachments

(1 attachment)

>>>   My Info:   Win7_64, Nightly 46, 32bit, ID 20160126030244
STR:
1. Copy "http://example.org/" (without quotes) in clipboard
2. Open  downloads panel (Ctrl+J), Paste the string copied in Step 1 (Ctrl+V) to start download
3. Copy "example.org" (without quotes) in clipboard
4. Open  downloads panel (Ctrl+J), Paste the string copied in Step 3 (Ctrl+V)
5. Close downloads panel (Ctrl+W), then open it again (Ctrl+J)

Result:       Downloads are displayed as history/bookmark items.
Expectations: Downloads should always be displayed the same way.

This was triggered by bug 945707 (presumably). Regression range:
> http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=73eefb421e2a&tochange=735a648bca0d

Screenshot
> https://dl.dropboxusercontent.com/s/s1xu2krf3g9ht37/screenshot%201%20-%20Items%20in%20downloads%20panel%20are%20displayed%20as%20history%20items.png?dl=0
>>>   My Info:   Win7_64, Nightly 51, 32bit, ID 20160805030444 (2016-08-05)
Reproducible.
Actually, I just used this bug to easily access saved urls and SORT them.
Sorting doesn't work by default, but it's another bug.
Hi :Paolo,
This bug is a regression and is assigned to nobody and we need someone to work on this. Since it seems that you are involved in this, could you help to take a look at this?
Flags: needinfo?(paolo.mozmail)
Flags: needinfo?(paolo.mozmail)
Summary: Items in downloads panel are displayed as bookmarks/history items, after I accidentally broke it by pasting invalid url → Pasting an invalid URL breaks the Downloads View in the Library (downloads are displayed as history items)
Marco is not back yet, so asking Jared for review. The actual fix is checking that the command is enabled to prevent pasting a wrong URL in the first place, but I also added error handling so that if an invalid source URL is created somehow, the view does not break entirely.
Assignee: nobody → paolo.mozmail
Status: NEW → ASSIGNED
Comment on attachment 8783529 [details]
Bug 1243445 - Pasting an invalid URL breaks the Downloads View in the Library.

https://reviewboard.mozilla.org/r/73316/#review71140
Attachment #8783529 - Flags: review?(jaws) → review+
Pushed by paolo.mozmail@amadzone.org:
https://hg.mozilla.org/integration/fx-team/rev/c2208aa03218
Pasting an invalid URL breaks the Downloads View in the Library. r=jaws
https://hg.mozilla.org/mozilla-central/rev/c2208aa03218
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 51
I have reproduced this bug with Nightly 47.0a1(2016-01-27) on Elementary OS 64bit

This bug's fix is now verified in latest Nightly 51.0a1

Build ID 	20160901030202
User Agent 	Mozilla/5.0 (X11; Linux x86_64; rv:51.0) Gecko/20100101 Firefox/51.0

[bugday-20160831]
Please request uplift approval for FF 50.
Flags: needinfo?(paolo.mozmail)
Flags: needinfo?(jaws)
Comment on attachment 8783529 [details]
Bug 1243445 - Pasting an invalid URL breaks the Downloads View in the Library.

Approval Request Comment
[Feature/regressing bug #]: bug 945707
[User impact if declined]: pasting an invalid URL in to downloads view of the library causes the downloads items to appear as bookmarks/history
[Describe test coverage new/current, TreeHerder]: manual testing, verified on nightly, landed on m-c for a couple weeks now
[Risks and why]: none expected
[String/UUID change made/needed]: none
Flags: needinfo?(paolo.mozmail)
Flags: needinfo?(jaws)
Attachment #8783529 - Flags: approval-mozilla-aurora?
Comment on attachment 8783529 [details]
Bug 1243445 - Pasting an invalid URL breaks the Downloads View in the Library.

Recent regression, fix was verified in Nightly, Aurora50+
Attachment #8783529 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Flags: qe-verify+
I managed to reproduce this issue on 50.0a1 (2016-08-01). It is verified fixed on 50.0b2 build1 (20160926162149), using Windows 10 x64, Ubuntu 14.04 x86 and Mac OS X 10.11.6.
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.