Images don't redraw if animation/transition is canceled in the middle

RESOLVED DUPLICATE of bug 1243409

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 1243409
2 years ago
2 years ago

People

(Reporter: arni2033, Unassigned)

Tracking

({regression, regressionwindow-wanted})

Trunk
regression, regressionwindow-wanted
Points:
---

Firefox Tracking Flags

(firefox47 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8712755 [details]
screenshot 1 - Images don't redraw if animation transition is canceled in the middle.png

>>>   My Info:   Win7_64, Nightly 46, 32bit, ID 20160126030244
STR:
1. Save testcase from comment 1, open .htm file in firefox. I discovered the bug while using Tumblr
2. Click on the page
3.A) As fast as possible {press button that produces 'keyup'} (x4 times)
     I do it like this:   successively press keys "k", "j" in ~0.5 second
3.B) (in more detail) Press "k" key, then, while transition is still not finished, press "j" key

AR: Images don't redraw: you can see several parts of each image in different places (see screenshot)
ER: Images should redraw correctly

2015-04-06 - OK,   2016-01-26 - affected
(Reporter)

Comment 1

2 years ago
So, here's "testcase 1": attachment 8712754 [details] from bug 1243446
See Also: → bug 1243446, bug 1204336
This is probably a regression from my refactoring but I won't be available to look at this for some time.
Flags: needinfo?(bbirtles)
I did mozregression.

https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=c525c5164cdde373a636d525e53c77f52d8fd693&tochange=c99e8abb5e00eaa439a3be7864df0e4135326349

mattwoodrow, can you please take a look this?
Component: DOM: Animation → Layout
Flags: needinfo?(matt.woodrow)
I believe this is a duplicate of bug 1243409.
Flags: needinfo?(matt.woodrow)
Thank you, mattwoodrow!
I confirmed the patch in bug 1243409 fixes this issue.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(bbirtles)
Resolution: --- → DUPLICATE
Duplicate of bug: 1243409
status-firefox47: affected → fixed
You need to log in before you can comment on or make changes to this bug.