Show unsupported warning for servers that are too old

RESOLVED WONTFIX

Status

()

Firefox
Developer Tools: WebIDE
P2
normal
RESOLVED WONTFIX
2 years ago
9 months ago

People

(Reporter: jryans, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox47 affected)

Details

(Whiteboard: [btpp-fix-later])

We recently decided to reduce the compatibility window[1] by no longer requiring long term (multi year) support for Firefox OS.

This means we're more likely to encounter unsupported servers which are too old.  WebIDE should show a warning in the case and try to suggest the right client to use instead.

[1]: https://groups.google.com/d/topic/mozilla.dev.developer-tools/RiKZhVbgn8o/discussion
There is an existing "server too new" warning:

https://dxr.mozilla.org/mozilla-central/source/devtools/client/webide/content/webide.js#903

Should be easy to extend this.
Priority: -- → P2
Whiteboard: [btpp-fix-later]
WebIDE is slated for removal (bug 1314811), so there are no plans to add to the current set of features.
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.