FF44 Linux: New windows always opening at 800x600

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: crxssi, Unassigned)

Tracking

44 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20160123151951

Steps to reproduce:

Mageia 5 Linux, KDE

I upgraded my plain-vanilla Firefox (official binary build from mozilla.org) from 42 to 44.


Actual results:

When I open a link in a new window, it used to remember the size and open the new window the same size as the previous window.


Expected results:

Now it opens a small new window every time, regardless of the size of the originating window.  xwininfo reports it is always exactly 800x600.  Why is it doing this?  It ruins my workflow and usability!
(Reporter)

Updated

2 years ago
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
(Reporter)

Comment 1

2 years ago
I think I reported too quickly.  I downgraded to Firefox 43, same behavior.  Downgraded to 42 (what I was using before) same behavior.  Wiped $HOME/.mozilla, same behavior.  So then I ran Firefox remotely from work (which I used today at work with no issue)  SAME BEHAVIOR!  Then I remembered, right at the same time I updated Firefox, I also allowed Mageia to install a bunch of updates.  So perhaps it is something in one of those?  I am still researching.  There are a lot of packages upgraded (166), and I am not sure which could possibly cause this type of behavior for Firefox.  But the ones I would expect could maybe have such an impact were not updated (X11, KDE, GTK)
(Reporter)

Comment 2

2 years ago
It is now fixed, but I don't know how.  Seems to be related to KDE somehow.  Doesn't happen in icewm, nor lxde and when I went back into KDE, it suddenly started acting normally again.

Spooky.  I am closing as invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.