Artifacts left on chart on OS X

RESOLVED FIXED in Firefox 47

Status

()

Core
Layout
RESOLVED FIXED
2 years ago
a year ago

People

(Reporter: jrmuizel, Assigned: mattwoodrow)

Tracking

({regression})

Trunk
mozilla47
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox47 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Hover over some data points here:
https://quixdb.github.io/squash-benchmark/

Stuff gets drawn and left behind.

This is a recent regression.
(Reporter)

Updated

2 years ago
Keywords: regression, regressionwindow-wanted

Comment 1

2 years ago
Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=f3b54b8458bf70534cc442284f27ee43b877c996&tochange=296fd9d50c25669702b047efb216ed90bc9f22e8
Comment hidden (obsolete)

Updated

2 years ago
Blocks: 1240985

Comment 3

2 years ago
Created attachment 8713006 [details]
screenshot

Updated

2 years ago
No longer blocks: 1240985

Comment 4

2 years ago
pls ignore comment 1.

Comment 5

2 years ago
corrected pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=c525c5164cdde373a636d525e53c77f52d8fd693&tochange=c99e8abb5e00eaa439a3be7864df0e4135326349

suspect :Bug 1221842
Blocks: 1221842
Check if the patch in bug 1243409 fixes this when it lands.
Hi Jeff,

I haven't managed to reproduce this issue on the latest release(44.0.2) nor latest Nightly(47.0a1). I've tested on Mac OS X 10.11. If I hover over any of the graphs, I don't get any bad drawings as seen in the attachment from comment 3.

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20160210153822

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160222030212

Can you please share more information on your environment? What version of OS X did you use when you encountered this bug? Did you encounter this issue on Nightly, Aurora, Beta or release? Is this reproducible only with e10s enabled?

Also, can you please try to reproduce this on the latest release(44.0.2) and latest Nightly(47.0a1) and provide the results? When doing this, please try to reproduce with a new clean Firefox profile, maybe even in safe mode, as some of this issues may be caused by third party installed add-ons or custom settings(https://support.mozilla.org/en-US/kb/troubleshoot-and-diagnose-firefox-problems).

Thanks,
Paul.
Flags: needinfo?(jmuizelaar)
(Reporter)

Comment 8

2 years ago
This seems to work now.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(jmuizelaar)
Resolution: --- → FIXED
Assignee: nobody → matt.woodrow
status-firefox47: --- → fixed
Depends on: 1243409
Keywords: regressionwindow-wanted
Target Milestone: --- → mozilla47
Version: unspecified → Trunk
You need to log in before you can comment on or make changes to this bug.