shortcut for Composer doesn't work in (jsconsole|bookmarks|history|chatzilla|...)

VERIFIED DUPLICATE of bug 122271

Status

SeaMonkey
Composer
VERIFIED DUPLICATE of bug 122271
17 years ago
14 years ago

People

(Reporter: Adam Hauner, Assigned: Charles Manske)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Repro:
1. open JS console
2. press Ctrl+1

Actual:
nothing happens

Expected:
New browser window should open (because in JS console's menu is for Task |
Navigator displayed this shortcut). It's same for other Mozilla's component.

2002020703/WinNT4
(Reporter)

Comment 1

17 years ago
Oops, it's working now (after posting bug) for all component except Composer.
When I choose Composer, on JS console appears error:

Error: NewEditorWindow is not defined
Source File: chrome://communicator/content/tasksOverlay.js
Line: 150
Summary: shortcuts for Mozilla's component doesn't work in JavaScript console → shortcut for Composer doesn't work in JavaScript console

Comment 2

17 years ago
NewEditorWindow is defined in editorApplicationOverlay.js, which is 
included in editorNavigatorOverlay.xul, which is overlayed (via the 
chrome registry) onto navigatorOverlay.xul, which console.xul does 
not use (hence, no function NewEditorWindow() is in scope). 

But it seems wrong that you can overlay tasksOverlay.xul and not get
what everything you need to make the various tasks work correctly in 
a window.

Comment 3

17 years ago
I meant to cc: cmanske earlier (see above). I just tried 'Tasks->Composer' 
in bookmarks, chatzilla and history, in addition to the js console, and they 
all throw the same error (for the same reason, above).

I'm not sure how this should be organized, but this is a Composer bug.
Assignee: hewitt → cmanske
Component: JavaScript Console → Editor: Composer
Summary: shortcut for Composer doesn't work in JavaScript console → shortcut for Composer doesn't work in (jsconsole|bookmarks|history|chatzilla|...)

Updated

17 years ago
QA Contact: jrgm → sujay
(Assignee)

Comment 4

17 years ago
this issue is being worked on.

*** This bug has been marked as a duplicate of 122271 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 5

17 years ago
verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.