bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Add --browser-chrome and --chunk-by-runtime flags to browser-chrome-coverage test

RESOLVED FIXED in Firefox 47

Status

Testing
Code Coverage
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Trung Do, Unassigned)

Tracking

Trunk
mozilla47
Points:
---

Firefox Tracking Flags

(firefox47 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

1.58 KB, patch
Chris Manchester (mostly offline July 16-20)
: review+
Details | Diff | Splinter Review
(Reporter)

Description

3 years ago
Created attachment 8713202 [details] [diff] [review]
mozharness.patch

This is a patch by Joel Maher to enable browser-chrome tests for browser-chrome-coverage.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 1

3 years ago
Comment on attachment 8713202 [details] [diff] [review]
mozharness.patch

ask :chmanchester
(Reporter)

Updated

3 years ago
Attachment #8713202 - Flags: review?(cmanchester)
Comment on attachment 8713202 [details] [diff] [review]
mozharness.patch

Review of attachment 8713202 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks for the patch. Have we confirmed this does exactly what we want on try? If so just ping me and I'll get it landed.
Attachment #8713202 - Flags: review?(cmanchester) → review+
(Reporter)

Comment 3

3 years ago
Yes, for example we can see the generated .json files here: https://tools.taskcluster.net/task-inspector/#czDtRRwmT8uAE-5lmq7_eg/0
Trung, can you please update the commit message on this patch so I can land the patch? Thanks. Details on the commit message format can be found here: https://developer.mozilla.org/en-US/docs/Mozilla/Developer_guide/Committing_Rules_and_Responsibilities
Flags: needinfo?(chin.bimbo)
(Reporter)

Comment 5

3 years ago
Created attachment 8714468 [details] [diff] [review]
c.patch

Here is the patch with modified commit message
Attachment #8713202 - Attachment is obsolete: true
Flags: needinfo?(chin.bimbo)
(Reporter)

Updated

3 years ago
Attachment #8714468 - Flags: review?(cmanchester)
Comment on attachment 8714468 [details] [diff] [review]
c.patch

Review of attachment 8714468 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks! This needs "r=chmanchester" at the end to indicate the reviewer, but I'll just add that before landing. Re-requesting review in this case isn't necessary because the code hasn't changed.
Attachment #8714468 - Flags: review?(cmanchester) → review+

Comment 8

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/96c92e9d6216
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox47: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla47
You need to log in before you can comment on or make changes to this bug.