Closed Bug 1243910 Opened 6 years ago Closed 6 years ago

Firefox 44.0 Doesn't launch from Windows Taskbar

Categories

(Toolkit :: Startup and Profile System, defect)

44 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1243098

People

(Reporter: bryanob3, Unassigned)

Details

(Whiteboard: [44dll])

Crash Data

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20160105164030

Steps to reproduce:

Hello,
I was using Firefox 43.0.4 without issues. I just upgraded to Firefox 44.0.



Actual results:

I cannot launch Firefox from Windows 7 Pro (64-bit SP1) Taskbar.
I checked the Task Manager/Process and noticed that the (firefox.exe *32) process started briefly and then disappeared. That behavior was repeatable.
The Taskbar shortcut had the correct path.

I then used the shortcut the installer placed on my desktop, just in case something was wrong with the Taskbar shortcut.
Firefox was launched, but I could not open any tabs or cruise the Internet. I tried MS IE and that worked, so there was nothing wrong with my network connectivity.

I then tried launching Firefox from the Start menu shortcut.
Firefox was launched and worked normally as expected.

Next, I uninstalled Firefox 44.0 and reinstalled 43.0.4.
Firefox was launched and worked normally as expected.


Expected results:

I had always used the Taskbar shortcut to launch Firefox and now it doesn't work, so something had changed.
Secondly, the desktop shortcut should've also worked.
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64
Version: 43 Branch → 44 Branch
I observe a slightly different pattern: Here, Firefox 44.0 starts from the taskbar, but it crashes on exit every time. On next startup, it crashes again (obviously during crash reporter initialisation, which works only 1 out of 20 times).

Everything works fine if Firefox is started from the start menu. Windows 7 SP1 x64 here as well. No problem with the previous versions.

This is taskbar and 44.0 specific and seems to be a common problem, see also here: http://www.adslzone.net/postt402338.html
FWIW: I just upgraded to 45.0b1 and that works fine. Go figure.
It was too late yesterday: I just found that I installed the 64bit version. The 32bit version of 45.0b1 crashes on exit just like 44.0. Downgrade to 43.0.4 32bit fixes that.

I saw in another bug that most if not all people affected use NVidia cards - I use one, too, with a current driver.
For what it's worth, I too use an NVIDIA video card. GeForce GTX 570.
I have tried to switch to the standard VGA card driver - it still behaves the same way. I also tried a Win7 VM with a plain vanilla installation (and obviously no NVidia card) that works just fine.

I am at a loss what is causing this.
Hi guys, 

I have tested this issue and I can't reproduce it on win 7 with Firefox 44 and Firefox Nightly 47.0a1.

Please install Firefox Nightly 47.0a1 and retest the problem, use this link to download Nightly build: https://nightly.mozilla.org/
Flags: needinfo?(bryanob3)
Just tested it. Crashes like 44.0 and 45.0b1, only when started from taskbar. Does not re-crash on next startup, though, which may be attributed to the side-by-side installation to 43.0.4.
Also please see bug 1243914, looks like this one, may be a duplicate.
Component: Untriaged → Startup and Profile System
Product: Firefox → Toolkit
very likely a dup of 1243098
Whiteboard: [44dll]
Just upgraded to 44.0.1 - still crahsing on exit.
Hi Dr. Uwe Meyer-Gruhl,

Hi,
Please get the Report ID of your latest crash report,in the address bar type about:crashes and provide us the latest ID crash, here you have a link to see how can you do that https://support.mozilla.org/en-US/kb/firefox-crashes-asking-support
Flags: needinfo?(f+bugzilla)
This was the most recent from 44.0.1:

bp-f8c9c105-aba4-4f49-87f7-eee6b2160208

I had many more crashes than what turns up in the about:crashes list, e.g. I have not found the crashes under 44.0 with all extensions disabled.
Flags: needinfo?(f+bugzilla)
Hi, I looked in crash report and this is the only crash with this signature in the last 28 days.
Crash Signature: [@ nvwgf2um.dll@0x599554 ]
As I wrote: There were plenty more crashes that were not recorded as Firefox 44.x mostly crashes once on exit and once on next startup, most probably during attempted crash reports.

I was lucky enough to have produced a few new reports just now, and these seem more correlated to other people's signatures:

bp-54675612-22ad-4c18-90ca-017bc2160209
bp-e7dccbc0-df75-4c39-97df-90b462160209
bp-4da7c24c-9205-423b-968f-8da9c2160209
bp-fc697120-416b-4ac0-94e1-d37e72160209
bp-cbc77a0b-2688-40ea-8ceb-645452160209

However, I just deactivated all plugins manually and then turned off the "show tab previews on windows taskbar". After that: no more crashes. And now comes the best part: After I re-enabled the plugins and the tab previews, it stayed that way for a short while, but now the crashes have reappeared.

All I know for sure is that this does never happen with 43.0x.
Now I can say something more: The bug creeped in with 44.0b9. I tested many betas up to 44.0b8, all of these version were unaffected. 44.0b9 was affected, as was 44.0rc1.

I don't know how to see what commits are between these 44.0b8 and 44.0b9.
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1243098
I do not think it is an exact dupe. For the other bug, there is a startup error. Here, the next startup seems affected only because of the last exit had crashes.

For the diff above, I am convinced it has to to with how shutdown is handled. Around Firefox versions >43, there have been changes regarding bug 1238010 which points to 1233237. Obviously, sometimes, the Firefox process would hang during shutdown.

There are numerous cascading patches regarding how to circumvent crashes caused by an Nvidia network manager DLL when a certain NVidia network accelerator is present. These patches all point to some winsock DLLs and the way how the registration/blocking/detour of networking DLLs are handled at startup and how the network IO is handled on shutdown (cf 'ClosingService').

I read some discussions about threadsafety which I did not understand fully (neither did some of the people that discussed those bugs). I get the impression that the fix of the initial small problem caused a cascade of changes (detour instead of hooking DLLs, using another thread than the original one for closing the sockets, not closing the sockets asynchronously at all) which cause the observed, often seemingly nondeterministic problems.
Flags: needinfo?(bryanob3)
You need to log in before you can comment on or make changes to this bug.