Closed Bug 1243979 Opened 4 years ago Closed Last year

[e10s] Enable browser_webconsole_bug_595934_message_categories.js in e10s

Categories

(DevTools :: Console, defect, P2)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1404384

People

(Reporter: linclark, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [console-rewrite-fix])

No description provided.
Blocks: 1112599
Blocks: e10s-tests
tracking-e10s: --- → +
Priority: -- → P1
Bug 595934 for reference

This tests that the console displays messages for different kinds of page errors. To make this more efficient, I believe we can write this as:

- 1 end-to-end test to make sure a single page error is handled and flows through _onPageError and .handlePageError, out to the console
- A unit test for each type

It seems to me that the end-to-end test is the P1 here. The pipeline is what could break with e10s. For the unit tests, that can wait until we implement it as part of the console rewrite. (and for that, we can probably get error packets directly using the logic in https://dxr.mozilla.org/mozilla-central/source/devtools/shared/webconsole/test/test_page_errors.html)
Priority: P1 → P2
Whiteboard: [console-rewrite-fix]
Product: Firefox → DevTools
Status: NEW → RESOLVED
Closed: Last year
tracking-e10s: + → ---
Resolution: --- → DUPLICATE
Duplicate of bug: 1404384
You need to log in before you can comment on or make changes to this bug.