Feature: Need a built-in inline editing capability

RESOLVED FIXED

Status

()

P3
normal
RESOLVED FIXED
19 years ago
2 years ago

People

(Reporter: slogan, Assigned: bugs)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3-]4 days, needs owner, has implications for selection in treeview.)

(Reporter)

Description

19 years ago
We need some widget that has the ability to provide visual clues to the user
that it can be pressed (meaning, it should probably look like a titledbutton),
but can be configured dynamically to become an editable field. This is needed
for in-place editing of tree items in our particular case.

Updated

19 years ago
Status: NEW → ASSIGNED
Summary: Need a widget that can act like an editable pushbutton → Feature: Need a widget that can act like an editable pushbutton
Target Milestone: M11
If we don't want to embed a webshell/editorshell in the edited button, we could
use a neat trick from the Gnumeric guys: create an invisible editor widget and
then proxy events to it, and observe content/selection.  Maybe it's no big
deal to put an editorshell in the button, or swap them out, or something.

Updated

19 years ago
Severity: critical → normal
Target Milestone: M11 → M14

Comment 2

19 years ago
I believe this to be very low priority. Shoving off to M14.

Updated

19 years ago
Assignee: hyatt → shaver
Status: ASSIGNED → NEW

Comment 3

19 years ago
reassigning to shaver per hyatt

Comment 4

19 years ago
spam: changing qa contact from ckritzer -> paulmac for xul bugs

Comment 5

19 years ago
BULK MOVE: Changing component from XUL to XP Toolkit/Widgets: XUL.  XUL 
component will be deleted.
Component: XUL → XP Toolkit/Widgets: XUL

Comment 6

19 years ago
Taking back.
Assignee: shaver → hyatt

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M14 → M19

Comment 7

19 years ago
qa to jrgm
QA Contact: paulmac → jrgm

Comment 8

19 years ago
There is no cross-app demand for this, and we have no time to do it in the
current release.  resolving as later
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → LATER

Comment 9

19 years ago
This functionality is needed for an important AIM beta 2 feature.  Reopening and 
requesting for the M15 or M16 milestone.
Status: RESOLVED → REOPENED
Resolution: LATER → ---

Comment 10

19 years ago
The feature is inline editing of the buddy list, BTW.

Comment 11

19 years ago
adding duration swag.  
Summary: Feature: Need a widget that can act like an editable pushbutton → Feature: Need a built-in inline editing capability
Whiteboard: 4 days, needs owner, has implications for selection in treeview.
Target Milestone: M19 → M17

Comment 12

19 years ago
Mass moving M17 bugs to M18
Target Milestone: M17 → M18

Comment 13

19 years ago
Mass-moving feature bugs back to M17
Target Milestone: M18 → M17

Comment 14

19 years ago
...
Assignee: hyatt → ben
Status: REOPENED → NEW

Comment 15

19 years ago
Move to M20.
Target Milestone: M17 → M20

Comment 16

19 years ago
inline editing for bookmarks in the treeview has been a product requirement (low priority) from the begining as well.

Comment 17

19 years ago
*** Bug 38749 has been marked as a duplicate of this bug. ***
I don't know if in the Brave New World of ender lite my situation here is any 
simpler, but I tried to  knock together a primitive implementation of this 
some time ago with ender and the problem I ran into was that I had to 
specify a size (using the 'size' attribute) on the text field to get it to show up, 
and that left an awkwardly sized textfield whose width had no relation to 
the length of the element being inline-edited.

Maybe I was doing something wrong. This is a highly desirable feature, 
will have a look in the nsbeta3 timeframe. 
Status: NEW → ASSIGNED

Updated

19 years ago
Keywords: nsbeta3

Comment 19

19 years ago
nav triage team:
nsbeta3-
Desirable feature, but easy to live without (didn't have it in 4.x).  Bummer, 
but we got to ship this puppy.  Feature did not make it in time.
Whiteboard: 4 days, needs owner, has implications for selection in treeview. → [nsbeta3-]4 days, needs owner, has implications for selection in treeview.
I want to fix this for 1.0/6.5

Comment 21

18 years ago
Inline editing has been implemented for trees and Ben has another bug to do it 
for outliners (patch attached).  Any more work needed here?
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago18 years ago
Resolution: --- → FIXED

Updated

10 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.