Firefox 43: clearing cache not working

RESOLVED INVALID

Status

()

RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: jeff, Unassigned)

Tracking

43 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20160106231004

Steps to reproduce:

Edit->Preferences->Advanced->Network->
    * Cached Web Content->Clear Now
    * Offline Web Content and User Data->Clear Now


Actual results:

Despite clearing the cache, all visited links remain "hot" rather than being reset to an unvisited state.  In earlier versions of Firefox, clearing the cache also cleared these links.


Expected results:

Links should be cleared.
(Reporter)

Updated

3 years ago
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
Component: Untriaged → Networking: Cache
Product: Firefox → Core
(In reply to Jeffery Small from comment #0)
> Despite clearing the cache, all visited links remain "hot" rather than being
> reset to an unvisited state.  In earlier versions of Firefox, clearing the
> cache also cleared these links.

I don't understand what 'links remain "hot"' means.  Can you clarify?

> 
> 
> Expected results:
> 
> Links should be cleared.
Flags: needinfo?(jeff)
(Reporter)

Comment 2

3 years ago
Sorry for the imprecise language.  I mean that previously visited links continue to display as visited (CSS: a:visited) rather than being reset to the unvisited state (CSS: a:link) as has always occurred in the past when clearing the cache.  

Has the "visited" list somehow been decoupled from the cache?  If that turns out to be the case, how do you reset all links to an unvisited state and shouldn't clearing the cache still clear all "visited links"?
Flags: needinfo?(jeff)
You must delete browsing history.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INCOMPLETE
Resolution: INCOMPLETE → INVALID
(Reporter)

Comment 4

3 years ago
OK.  I went looking for this and did not find it on the Preferences tabs but did see it on the History Pull-down menu (Ctrl+Shift+Del) and this does work.  Thank you for the feedback.  For years I'm sure I have been clearing the cache and getting this result.  Did something recently change?
The UI has changed last time years ago, I think.  And cache never had anything to do with browser history, it was always a different thing.
(Reporter)

Comment 6

3 years ago
OK, thanks for the info.  My best guess then is that, for me, the history and the cache were previously linked and got cleared at the same time and somehow they got decoupled.  I always seem to remember using the "Clear Cache" button on the Preference menu to do the job, but maybe it was the Clear Recent History menu and I'm just forgetting.

Anyway, thanks for straightening me out and sorry to bother the bug list with something that was not actually a bug.

Regards,
--
Jeff
You need to log in before you can comment on or make changes to this bug.