permission to Run custom queries in super search/Long Queries at SOCORRO--crashstats.mozilla.com

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
3 years ago
2 years ago

People

(Reporter: amraj, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Comment hidden (empty)
(Reporter)

Comment 1

3 years ago
Peter Bengtsson <peterbe@mozilla.com>: Can you please vouch for me.
Hi Amraj,
I know you have permission to upload symbols. 

Why do you need to run custom queries in Super Search?
Why do you need to run long queries?

As a rule, we have not given out other permissions to non-Mozilla-staff. Can you please needinfo your point of contact here at Mozilla who can help you justify the permission upgrade requirement.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 3

3 years ago
Hi Team,

Our requirement is to see crashes details(count) on mozilla due to Flash player plugin.
Report/Graph/Count based on Flash version with different parameters.
For that we wanted to hit socorro database/fetch data through query.
Is there any other way to receive those information? Appreciate the help.

Thanks,
Amrit
(In reply to amraj from comment #3)
> Hi Team,
> 
> Our requirement is to see crashes details(count) on mozilla due to Flash
> player plugin.
> Report/Graph/Count based on Flash version with different parameters.
> For that we wanted to hit socorro database/fetch data through query.
> Is there any other way to receive those information? Appreciate the help.

You can do all of that regular SuperSearch. If not, let's deal with where it doesn't work. 

I'm CC'ing Adrian too who is our SuperSearch expert.
Hello Amraj,

As far as I know, we cannot give you access to custom searches, since that would give you access to all of our data, including sensitive data and PII. Long queries is useful if you want to run searches over a long period of time, which doesn't seem to be the case here. I believe, as Peter said, that you can do everything you need with Super Search. 

Here's an example search that gives back all results where "flash version" is different from "[blank]" (I suppose that means all those results have a flash player installed? ): 

https://crash-stats.mozilla.com/search/?product=Firefox&flash_version=![blank]&_facets=flash_version&_columns=flash_version

From there on you can add more filtering, or some faceting (look at the "More options"), or you can go to the API to get the data as JSON: 

https://crash-stats.mozilla.com/api/SuperSearch/?product=Firefox&flash_version=!%5Bblank%5D&_facets=flash_version&_columns=flash_version&_facets=flash_version

Documentation for Super Search's API will be available very soon, it is currently under review. See bug 1227904. In the meantime, don't hesitate to ask more questions, I'll be happy to help you get the data you need out of Super Search.
(Reporter)

Comment 6

3 years ago
Hi Adrian,

Thanks for the updated information. I will check and let you know if any issues.

Thanks,
Amrit

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.