Text render bug for linux

RESOLVED WORKSFORME

Status

()

Core
Graphics: Text
--
minor
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: alexcoffin1999, Unassigned)

Tracking

44 Branch
Unspecified
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gfx-noted], URL)

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8713507 [details]
2016-01-28_23-38-56.flv

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20160128013150

Steps to reproduce:

Visit http://www.twitch.tv/ WITHOUT FLASH INSTALLED. I would say how to recreate it without visiting the site but I am not sure why it is happening and seems to be a very specific bug that requires position: absolute, text-align: center, specific font-sizes then using font-size with em.

The bug should be were the video player would be if you had flash turned on. Where the text says "No supported video backend available; Flash is not installed".

Reproducing:
1. Can't have flash installed (because of website not because of bug itself)
2. Have to use firefox on linux. I tested it on windows and it renders correctly (on the same hardware I dual-boot so I doubt its my hardware although it could be).

Running firefox version 44.0 on linux mint version 17.3 Rosa

If this matters I have tried resizing the window and it still glitches even then.


Actual results:

In the video player the text (IF FLASH ISN'T INSTALLED) which says "No supported video backend available; Flash is not installed" has the n in "backend" constantly shifting left and right. It's really weird. A visual of this is in the attached file.


Expected results:

The text should not shake and move.
(Reporter)

Updated

2 years ago
Severity: normal → minor
OS: Unspecified → Linux

Comment 1

2 years ago
Created attachment 8713560 [details]
2016-01-28_23-38-56.mp4

Use mp4 next time, please.

Updated

2 years ago
Component: Untriaged → Graphics: Text
Product: Firefox → Core
(Reporter)

Comment 2

2 years ago
I apologize for not using an mp4 I just used the default of the recording software.

Updated

2 years ago
Whiteboard: [gfx-noted]

Comment 3

2 years ago
User Agent 	Mozilla/5.0 (X11; Linux x86_64; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID 	20160202030232

I reproduced this on Firefox 44, but not on Nightly 47.0a1. Seems to be fixed in latest Nightly. Could you test also in Nightly 47 and confirm if works as expected? You can download Nightly from https://nightly.mozilla.org/.
Flags: needinfo?(alexcoffin1999)
(Reporter)

Comment 4

2 years ago
Alright I'll download the nightly tonight and see if is fixed
Flags: needinfo?(alexcoffin1999)
(Reporter)

Comment 5

2 years ago
Fixed. Finally tested it on nightly. (tested version 47)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.