Composer change relative link to a file link when saving

VERIFIED DUPLICATE of bug 122227

Status

SeaMonkey
Composer
VERIFIED DUPLICATE of bug 122227
16 years ago
13 years ago

People

(Reporter: R Matthews, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8) Gecko/20020204
BuildID:    2002020415

Using the composer I edit a file with links like <a
href="/download.html">downloads</a> and <a
href="http://www.junit.org">Junit</a>.  The former, after saving (in the file
but not within the composer window), get converted to <a
href="file:///download.html">.  The url with the protocol specified is left alone.

Reproducible: Always
Steps to Reproduce:
1.Create html file with an <a> tag with a relative url e.g.,
  <a href="page.html">test</a>
2.Load it into the browser and check link
3.Select File/Edit Page and change the page - add a line etc.
4.Save the file and click on the source tab which shows:
<head>
  <title></title>
  <base href="file:///home/rcm/test2.html">
</head>
<body>
<a href="page.html"><br>
<br>
test</a>
</body>
</html>

5. If you look at the file (using cat or an editor) it shows no <base> tag and
the <a> tag is changed to 

<head>
  <title></title>
  <base href="file:///home/rcm/test2.html">
</head>
<body>
<a href="page.html"><br>
<br>
test</a>
</body>
</html>



Expected Results:  The base tag should not automatically be set - unless you
give me the ability to set it.  Presumably this would stop the rest being
changed.  If you provide the ability to set the <base> tag then it should remain
in the document as such and not just be used to change the urls.

Comment 1

16 years ago
Mathews, I think this is a DUP of bug 122227

If so, please mark it a DUP of that bug...thnks.
yes it is

*** This bug has been marked as a duplicate of 122227 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 3

16 years ago
verified.
Status: RESOLVED → VERIFIED

Comment 4

15 years ago
reassign in case bugs are reopened
Assignee: syd → composer
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.