backfilling jobs asks you to login when you're already logged in

RESOLVED DUPLICATE of bug 1259494

Status

RESOLVED DUPLICATE of bug 1259494
3 years ago
3 years ago

People

(Reporter: froydnj, Unassigned)

Tracking

Details

(Reporter)

Description

3 years ago
Selecting an orange job on mozilla-inbound asks me to login to treeherder to complete the action.  However, the icon in the upper right shows me that I'm logged in with my MoCo account.  Refreshing the page shows that I'm still logged in, so it's not a staleness issue.  Logging out and logging back in also doesn't seem to change anything.

Is this fallout from 2FA enablement?
Armen, any ideas?
Flags: needinfo?(armenzg)

Comment 2

3 years ago
emorley, mozci/pulse_actions does not deal with authentication on Treeherder. This is a TH issue.
I have not received any message on my side besides a different request [1]

<froydnj> armenzg: select a job, click the little dropdown with "retrigger / backfill this job", select "backfill", then get a request to login
<armenzg> froydnj, what auth prompt do you get?
<armenzg> buildapi? or treeherder's?
<armenzg> which push is this one? which job?
<armenzg> what email are you using when logged in?
<froydnj> armenzg: not sure?  it's not an LDAP dialog; it's a little red toast notification in the upper left that says "please login to treeherder to complete this action"

<froydnj> armenzg: it's this job: https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&fromchange=ad188676eb21&selectedJob=20741225
<froydnj> armenzg: I'm logged in with nfroyd@mozilla.com
<armenzg> froydnj, have you tried rebooting your browser or clearing the cache?
<froydnj> I have tried shift-reloading; I haven't tried clearing the cache or a browser reboot
<froydnj> nightly wants me to update, so I can try that, one moment
<froydnj> armenzg: restarting doesn't seem to have fixed it =/

[1]  th_runnable	 INFO:	 New jobs requested by nfroyd@mozilla.com for https://treeherder.mozilla.org/#/jobs?repo=try&revision=62399b781344
Flags: needinfo?(armenzg)

Comment 3

3 years ago
<froydnj> armenzg: huh, signing in on a different firefox gives me the same error...going to try chrome, I guess
<froydnj> armenzg: chrome gives the same error
<froydnj> armenzg: and I can confidently say I've never been to treeherder in chrome

Comment 4

3 years ago
FTR this worked for you earlier in the day since you managed to "add new jobs" through TH's UI earlier today.

retriggering jobs goes through Buildapi auth (if they're Buildbot jobs).
"adding new jobs" should auth in the same as "backfill" requests.

<armenzg> froydnj, can you take any other actions? a retrigger on a TaskCluster job?
<froydnj> armenzg: I've been able to retrigger jobs and add jobs in this browser session
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1259494
You need to log in before you can comment on or make changes to this bug.