When the SMTP Server requires StartTLS, authentication fails

RESOLVED DUPLICATE of bug 1182445

Status

()

RESOLVED DUPLICATE of bug 1182445
3 years ago
3 years ago

People

(Reporter: tom, Unassigned)

Tracking

5.0.2

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_2) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/47.0.2526.111 Safari/537.36

Steps to reproduce:

Have a mailserver that requires StartTLS before authentication
Try enabling (and disabling) TLS in the parameters



Actual results:

Didn't work
Then I hacked the source.
Worked


Expected results:

When starttls is offered by the server, bugzilla should automatically try and use, even if not specified or required in the parameters.
(Reporter)

Comment 1

3 years ago
I found #1082557 and basically undid the patch.  Then in Mailer.pm I replaced use Email::Sender::Transport::SMTP with use Email::Sender::Transport::SMTPS.

I create the transport object with $transport = Email::Sender::Transport::SMTPS->new

I set ssl => 'starttls'

Now I can send mail.

Updated

3 years ago
Assignee: general → email-notifications
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Component: Bugzilla-General → Email Notifications
Resolution: --- → DUPLICATE
Duplicate of bug: 1182445
You need to log in before you can comment on or make changes to this bug.