Closed Bug 1244318 Opened 7 years ago Closed 5 years ago

The last line in Console isn't visible if I close and reopen Console/switch to another tool and back

Categories

(DevTools :: Console, defect)

defect
Not set
trivial

Tracking

(firefox45 affected, firefox46 affected, firefox47 affected)

RESOLVED WORKSFORME
Tracking Status
firefox45 --- affected
firefox46 --- affected
firefox47 --- affected

People

(Reporter: arni2033, Unassigned)

References

(Blocks 1 open bug, )

Details

>>>   My Info:   Win7_64, Nightly 46, 32bit, ID 20160129030206

STR:
1. Open the following "data:" url or click URL in the form above
>   data:text/html,<meta http-equiv="content-type" content="text/html; charset=windows-1251"><script>for (i=0;i<1001;i++)console.log(i);</script>
2. Open devtools -> Inspector
(A)
3.A) Open devtools -> Console (Ctrl+Shift+K), scroll console messages to the very end
4.A) Switch back to Inspector tab, then to the Console again.
(B)
3.B) Toggle console visibility (Escape), scroll console messages to the very end
4.B) Toggle console visibility twice (Press Escape then Escape)

AR:  The last visible message is 999. I need to scroll to the very end _again_.
ER:  Console should be scrolled to the last message (1000) after Step 4, since I did that in Step 3.
Can confirm
Blocks: 1111089
Could not reproduce on the new console frontend
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.