option to compact ALL folders

VERIFIED DUPLICATE of bug 92999

Status

--
enhancement
VERIFIED DUPLICATE of bug 92999
17 years ago
10 years ago

People

(Reporter: tdavis, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; Q312461)
BuildID:    2002020406

It would be nice to have an option of compacting ALL folders.  Meaning, if I 
have deleted mail in all of my folders, rather than going to each folder and 
clicking "compact folder", have an option that says "compact all folders" and 
take care of it in one long operation.

Reproducible: Didn't try
Steps to Reproduce:
1. Go to edit
2. No option

Actual Results:  Nothing

Expected Results:  I expected to find the option

I know this operation can be painful to an imap server but it would be worth it 
at times.

Comment 1

17 years ago
Doesn't "File"/"Compact Folders" already do that?
(There is bug 93001 about also getting it into the context menu.=

Comment 2

17 years ago

*** This bug has been marked as a duplicate of 92999 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 3

17 years ago
Refer to bug 64751:
Our client had Compact (All) Folders feature for POP, Local and IMAP "Move to 
Trash" mode and "Delete Immediately" modes.
Refer to bug 94251, 105925:
Our client should change File Menu from "Compact Folders" to "Compact This 
Folder" for IMAP Mark as Deleted mode.

Verified as dup.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.