Closed Bug 1244494 Opened 5 years ago Closed 4 months ago

Thunderbird accepts incomplete email address in recipient/To field

Categories

(Thunderbird :: Message Compose Window, defect)

38 Branch
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 440377

People

(Reporter: suvegasncs, Unassigned)

References

()

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/48.0.2564.97 Safari/537.36

Steps to reproduce:

1) From ThunderBird Email Client, open/Write a new email window 
2) In the To address field, key in “invalidemail@invaliddomain”, key subject and email body content 
3) Click Send button (Refer to attached screen 


Actual results:

Thunderbird accepts the incomplete email address. 


Expected results:

Thunderbird should handle incomplete email address and alert user of invalid/unrecognisable email/To address, alert of something similar to as shown in attached screen "Expected_alert.png" example.
Please refer to the question raised by me for clarification/more information. 

https://support.mozilla.org/questions/1106605
To quote RFC 5321 

2.3.5.  Domain Names

A domain name (or often just a "domain") consists of one or more   components, separated by dots if more than one appears.  In the case   of a top-level domain used by itself in an email address, a single   string is used without any dots.  This makes the requirement,   described in more detail below, that only fully-qualified domain   names appear in SMTP transactions on the public Internet,  

How does the email address in your image digress from the description in the RFC?
See Also: → 312818
Please understand, I'm referring to external recipient/TO emails and not internal mail server.

The issue is faced by many of my users. 

Please see if Thunderbird can validate whether the entered email address (JustDomain) is an valid internal or an external mail server type. If it is not internal/local domain host, then Thunderbird should validate whether the keyed in email address is a complete/incomplete/unrecognisable/valid address. If the entered email is an incomplete address, Thunderbird should alert user and reject email address. Since many of my users are facing this issue, I would request Thunderbird to fix/enhance it to handle external email address.
I have the same issue, but it wasn't an address book issue, I copied & pasted the e-mail without the .com & it embarrassed me.

Please add it back in or fix it.

Thanks

This was fixed by bug 440377.

Status: UNCONFIRMED → RESOLVED
Closed: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 440377
You need to log in before you can comment on or make changes to this bug.