Experia Z3Compact has broken Gaia

RESOLVED FIXED

Status

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: wanjaustev, Assigned: nhirata)

Tracking

({foxfood})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Created attachment 8714050 [details]
video_2016-01-30_18-49-19.mov

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20160105164030

Steps to reproduce:

I powered on my phone. Upon booting there is no menu items but just what appears to be placeholders as seen in attached video. Even the camera button is not firing up the camera as one would expect.


Actual results:

The phone is not usable as it is as seen in attached video.


Expected results:

I expected to get a menu like the preceding Fxos devices like the flame. I cannot flash the device since it is covered under the agreement I signed when I was joining the program.
Component: Gaia::Foxfooding → Gaia
Keywords: foxfood
(Reporter)

Updated

3 years ago
Summary: Experia Z 3 has broken Gaia → Experia Z3Compact has broken Gaia
Hm, what you are running there is a prototype being worked on by etienne_s (current code is at https://github.com/kite-project/hope). You should not have been given a phone flashed with that one. Very strange.
(Reporter)

Comment 2

3 years ago
I agree it is strange since the person whom I had sent to bring the gadget with her from MozSummit at Singapore has hers working as expected. I think it was a small mix-up by the person who gave this to her to bring to me.

I wonder what can be done to rectify that since I am bound by the foxfooding agreement not to tamper with the phone.
Naoki, can you help Stephen with reflashing a foxfood build?
Flags: needinfo?(nhirata.bugzilla)
Hi Stephen,

Can I get information on which build number you are on?
Can I also get information on which channel you are on?

If you are on your own personal build, I would have to involve legal.  Please need info me again along with the response.
Flags: needinfo?(nhirata.bugzilla) → needinfo?(wanjaustev)
(Reporter)

Comment 5

3 years ago
Hi Naoki,

The phone is not giving me the menu as one would expect for a FxOS phone so I am not conversant of a way to tell of the OS I am running. See attached video. The phone is not even loaded with FXOS as far as I can tell, it is loaded with a prototype as commented on #c1 above. I also asked other foxfooders about it on discourse and you can see their replies here (https://discourse.mozilla-community.org/t/experia-z3-not-functioning-as-expected/6810/10).
Flags: needinfo?(nhirata.bugzilla)
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #4)
> Hi Stephen,
> 
> Can I get information on which build number you are on?
> Can I also get information on which channel you are on?
> 
> If you are on your own personal build, I would have to involve legal. 
> Please need info me again along with the response.

The prototypes phones at MozLando where flashed with dogfooding builds then had a custom gaia flashed on top of them.
But IIRC the settings app is not accessible with the proto flashed on.
(Reporter)

Comment 7

3 years ago
(In reply to Etienne Segonzac (:etienne) from comment #6)
> (In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from
> comment #4)
> > Hi Stephen,
> > 
> > Can I get information on which build number you are on?
> > Can I also get information on which channel you are on?
> > 
> > If you are on your own personal build, I would have to involve legal. 
> > Please need info me again along with the response.
> 

> The prototypes phones at MozLando where flashed with dogfooding builds then
> had a custom gaia flashed on top of them.
> But IIRC the settings app is not accessible with the proto flashed on.

Yes I can confirm the settings app is not accessible as the phone I have is clearly running the proto. What can be done to get the foxfood build on the phone?
Flags: needinfo?(nhirata.bugzilla)
I'm facing the exact same issue. I had written a mail few days back too regarding the same. Hope this get resolved soon.
Flags: needinfo?(etienne)
Which build were flashed on it?  I'm guessing then I can unmar a gecko/gaia fota for the update.zip and I can have them sideload the build.
(Reporter)

Comment 10

3 years ago
Personally there is no way I can tell the build since I can't access the settings menu on the phone. This is the only method I know of.

Are you aware of any other way to tell the build? I can see the device is listed at adb devices.
Flags: needinfo?(nhirata.bugzilla)
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #9)
> Which build were flashed on it?  I'm guessing then I can unmar a gecko/gaia
> fota for the update.zip and I can have them sideload the build.

Yep this should work.
The prototypes phone were taken out of the "foxfooding assembly line" and had a custom gaia flashed. Nothing else.
And it should be the same base build than other phone flashed for MozLando.
Flags: needinfo?(etienne)
My only concern, Etienne is that the data that's from the prototype might be causing the no booting in the first place.  In which case they would have to reset the data, right?  That would cause data loss...

To all the people experiencing this issue, would you mind the loss of your data?  We will try our best to keep it.  If you have ADB access, then you can give us your log of when it boots up by doing:
adb logcat -v time > logcat.txt
while it boots and giving us the logcat.txt file it generates.
Flags: needinfo?(nhirata.bugzilla)
(Reporter)

Comment 13

3 years ago
Created attachment 8716182 [details]
Bootlog  for Z3C - Steve

I don't have any data on the phone so there is no data to lose.

Please find attached log file.
Flags: needinfo?(nhirata.bugzilla)
Since you have adb access, Let's try reseting the phone first.
1. connect the device to the computer and type:
adb reboot recovery
2. using the volume keys ( up and down to navigate through the menu) move to the wipe data/factory reset
3. push the power button
4. select yes -- delete all user data... and hit the power button
5. wait for the format to complete.
6. select wipe cache partition and hit the power button
7. push the power button for reboot system now.

If resetting the device doesn't work in restoring the phone, and if you had signed the documentation agreeing to be in the dogfood program, then I can send you a build that contains the gecko and gaia portions and some instructions in regards to how to apply the build.  The Dogfood build has metricked information in which we collect data on how the phone are being used.  This is why a legal document has to be signed that you agree to the sending of this data.
Flags: needinfo?(nhirata.bugzilla)
(Reporter)

Comment 15

3 years ago
I have followed the procedure you have outlined above and nothing has changed. Same results as was before when I try to use the phone.
Flags: needinfo?(wanjaustev) → needinfo?(nhirata.bugzilla)
(Reporter)

Comment 16

3 years ago
I thought I should add that I signed the Foxfooding legal agreement with Mozilla too.
Looking at the build situation, I was able to reproduce the issue by flashing the 20151130130150 dogfood build and trying to sideload the 20151230201227 partial FOTA update.zip file.

I think it has to do with needing the fingerprint.  Ran a test build : https://tools.taskcluster.net/task-inspector/#A3nlsS1qS_yB-AOylnc0Og/0

I need to test sideloading the build first and then I'll setup the partial FOTA to point to this build if successful.
Made a slight mistake in the taskcluster json.  rebuilding at : https://tools.taskcluster.net/task-inspector/#facuulSmQl6qwepIxdK0Zw/
Flags: needinfo?(nhirata.bugzilla)
Assignee: nobody → nhirata.bugzilla
Not sure why it expired, can't seem to rerun it so I edit the task and ran it.  https://tools.taskcluster.net/task-inspector/#c48giPPzTaOReLnxlWLNAg/

May need to revisit and just push a new task.
Had to revisit.  it's for some reason taking a lot longer, added more time to see if that helps the task : 
https://tools.taskcluster.net/task-inspector/#bSyLChXORO6Msii2KfB4Gg/
Missing an s in my fingerprint, so it didn't upgrade.  Kicked off a new build : 
https://tools.taskcluster.net/task-inspector/#RcxvtasHSkeiWHBzugetXA/
The build I gave Stephen seems to work.
Not every one with this is affected, so updating balrog doesn't seem to be a good idea to me.

manrajsingh, where did you get your device and such?  Could you email my mozilla account so we can discuss your situation?  nhirata@mozilla.com
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(manrajsinghgrover)
Resolution: --- → FIXED
Hey nhirata! :) I got this device during Leadership Summit, Singapore this January. Issue seems to be the same as Stephen mentioned. I have mailed William and Brian few weeks back but not much have followed regarding this.

Should I put you in that mail loop?
Flags: needinfo?(manrajsinghgrover) → needinfo?(nhirata.bugzilla)
Hi nhirata, same for me, i got a Z3C during Leadership Summit in Singapore, and came with this very same build.

As we signed a foxfooding agreement, i dont know what steps to follow, tagging BKing here to clarify.
Flags: needinfo?(bking)
+ Valentin who has been thinking about a process for replacement phones.
Flags: needinfo?(bking) → needinfo?(vschmitt)
(Reporter)

Comment 26

3 years ago
Yes the build that Nhirata sent to me works as expected now. 
Thank you for tirelessly working to get the fix to me. I think it is easier to get the builds rather than the logistics and other issues that could be involved shipping phones.
(In reply to Brian King [:kinger] from comment #25)
> + Valentin who has been thinking about a process for replacement phones.

Thanks for flagging this Brian!
Flags: needinfo?(vschmitt)
Manraj, I would need the fingerprint for the phone.
adb shell getprop | grep fingerprint 
if you are on a mac.
Otherwise, do adb shell getprop and then look for the line that says ro.fingerprint
Flags: needinfo?(nhirata.bugzilla) → needinfo?(manrajsinghgrover)
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #28)
> Manraj, I would need the fingerprint for the phone.
> adb shell getprop | grep fingerprint 
> if you are on a mac.
> Otherwise, do adb shell getprop and then look for the line that says
> ro.fingerprint

For clarification, this command should also work on GNU/Linux, or any Unix based system with adb installed. :)
Hey Naoki,

I tried running the command but it says `error: insufficient permissions for device` . I can see the device listed on running `adb devices` though.
Flags: needinfo?(manrajsinghgrover) → needinfo?(nhirata.bugzilla)
Try updating now.  Otherwise you can try the steps here : 
https://discourse.mozilla-community.org/t/foxfooding-update-devices/7378/15

If the update doesn't work there's nothing that's going to hurt the device; it won't apply at all.
Flags: needinfo?(nhirata.bugzilla) → needinfo?(manrajsinghgrover)
Hey Naoki,

First of all, apologies! I got busy with my exams and college work and got free this week only. I have tried following the steps and downloaded the upload mentioned in comment 31. But it shows `error: insufficient permissions for device` on `adb reboot recovery`. On again checking `adb devices -l`, I see `YT9113PY3Y no permissions usb:1-2`. How to fix this?
Flags: needinfo?(manrajsinghgrover) → needinfo?(nhirata.bugzilla)
(In reply to Manraj Singh [:manrajsingh] from comment #32)
> Hey Naoki,
> 
> First of all, apologies! I got busy with my exams and college work and got
> free this week only. I have tried following the steps and downloaded the
> upload mentioned in comment 31. But it shows `error: insufficient
> permissions for device` on `adb reboot recovery`. On again checking `adb
> devices -l`, I see `YT9113PY3Y no permissions usb:1-2`. How to fix this?

Hey!
Just an idea: have you tried to run 'adb root' before flashing ?
(In reply to Valentin Schmitt [:ens0] from comment #33)
> (In reply to Manraj Singh [:manrajsingh] from comment #32)
> > Hey Naoki,
> > 
> > First of all, apologies! I got busy with my exams and college work and got
> > free this week only. I have tried following the steps and downloaded the
> > upload mentioned in comment 31. But it shows `error: insufficient
> > permissions for device` on `adb reboot recovery`. On again checking `adb
> > devices -l`, I see `YT9113PY3Y no permissions usb:1-2`. How to fix this?
> 
> Hey!
> Just an idea: have you tried to run 'adb root' before flashing ?

Hey! I just tried that. And again it says `error: insufficient permissions for device`. Is there a way to enable permissions?
Sound like there is an issue with the configuration with your linux box and your adb setup.

Did you make sure you setup the android rules for the device?
https://github.com/nhirata/android_rules
Flags: needinfo?(nhirata.bugzilla) → needinfo?(manrajsinghgrover)
Created attachment 8738500 [details]
IMG_20160406_165342231.jpg

Hey Naoki,

I guess I got it working now. Thank you helping in fixing this. Please review the attached screenshot.
Flags: needinfo?(manrajsinghgrover) → needinfo?(nhirata.bugzilla)
\o/

Thanks for letting us know and great!  Glad we got it resolved.
Flags: needinfo?(nhirata.bugzilla)
You need to log in before you can comment on or make changes to this bug.