Require passcode time starts after unlock and not after first lock

RESOLVED WONTFIX

Status

Firefox OS
Gaia::System::Lockscreen
RESOLVED WONTFIX
2 years ago
4 months ago

People

(Reporter: Radu-Bogdan Croitoru, Unassigned)

Tracking

({foxfood})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20160123151951

Steps to reproduce:

1. Go to settings
2. Select "Screen Lock"
3. Select "Passcode lock"
4. Setup require passcode "after 1 minute"
5. Play out on the phone for 2 minutes
6. Lock the screen
7. Unlock after 1-2 seconds


Actual results:

8. Passcode is required.


Expected results:

8. Passcode should not be required because the lock screen was enabled for less than 1 minute.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 1

2 years ago
Git commit info: f3cf488a
Model: Xperia Z3 Compact

Updated

2 years ago
Keywords: foxfood

Comment 2

2 years ago
I have this on the Flame as well. 

So it looks like the lockscreen counter is started immediately after passcode activation and not after the screen is turned off, which is what I would expect.

Comment 3

4 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.