the Folder Location widget on main toolbar is too narrow

RESOLVED FIXED in Thunderbird 47.0

Status

defect
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: aceman, Assigned: Paenglab)

Tracking

Trunk
Thunderbird 47.0
x86
Linux
Dependency tree / graph

Thunderbird Tracking Flags

(thunderbird45 fixed, thunderbird46 fixed, thunderbird47 fixed)

Details

Attachments

(2 attachments)

Posted image screenshot
Add the "Folder location" widget to the main toolbar.
The widget too narrow. The icon is not centered and even the focus ring does not encompass it but runs underneath the icon. When the widget is in the customize palette, its height is fine (it is higher than when placed on the toolbar).
I've also seen this on the no icon bug :) and have a patch ready.
This patch gives, like on Windows, menulists on main- and composer toolbars the same appearance as the toolbabutton-1.

Native menulists are taller than the 24px of the toolbabuttons which makes them shrink like on the screenshot. For example one of my Linux themes uses 6px borders and with this the menulist content would only have 12px space which is not enough.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #8714382 - Flags: review?(mkmelin+mozilla)
Attachment #8714382 - Flags: review?(mkmelin+mozilla) → review+
Keywords: checkin-needed
https://hg.mozilla.org/comm-central/rev/13181b2468b97b0c60b00596d997e3f3ed20cdcb
Bug 1244570 - Style the toolar menulists like toolbarbutton-1. r=mkmelin
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 47.0
Comment on attachment 8714382 [details] [diff] [review]
menulist.patch

[Approval Request Comment]
Regression caused by (bug #): 1242261 which has approval c-a and c-b
User impact if declined: too narrow menulist on main toolbar
Testing completed (on c-c, etc.): on c-c
Risk to taking this patch (and alternatives if risky): low
Attachment #8714382 - Flags: approval-comm-beta?
Attachment #8714382 - Flags: approval-comm-aurora?
Attachment #8714382 - Flags: approval-comm-aurora? → approval-comm-aurora+
Comment on attachment 8714382 [details] [diff] [review]
menulist.patch

http://hg.mozilla.org/releases/comm-beta/rev/e1989c919d60
Attachment #8714382 - Flags: approval-comm-beta? → approval-comm-beta+
Depends on: 1248158
Target Milestone: Thunderbird 47.0 → Thunderbird 45.0
Richard, the standard for release tracking is that Target Milestone is set for when the patch actually lands, and tracking flags are used for uplifts. Doesn't make a lot of sense, but that is the system.
Target Milestone: Thunderbird 45.0 → Thunderbird 47.0
You need to log in before you can comment on or make changes to this bug.