Scrolling and copy-paste do not work with many tabs openned

RESOLVED INCOMPLETE

Status

()

Firefox
Tabbed Browser
RESOLVED INCOMPLETE
2 years ago
2 years ago

People

(Reporter: Aleksey, Unassigned)

Tracking

43 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 2015122500

Steps to reproduce:

Open many tabs with real sites. Reproducible in all recent versions. 3x, 4x, etc.


Actual results:

Scrolling and copy-paste do not work with many tabs openned. Can't paste text to input fields (for example to comments box on youtube), on forums etc.


Expected results:

Scrolling and text past should work.
(Reporter)

Comment 1

2 years ago
In such cases forced to switch to Chrom where things work just fine.
(Reporter)

Updated

2 years ago
Component: Untriaged → Keyboard Navigation
OS: Unspecified → Linux
Hardware: Unspecified → x86_64

Comment 2

2 years ago
Can you reproduce this with a clean profile? How are you copying/pasting (keyboard, context menu, main menu, toolbar buttons, ... ?) Are there any errors in the browser console (ctrl-shift-j) when pasting fails? Are you using a distro build of Firefox, and if so, can you reproduce on an official build ( https://www.mozilla.org/en-US/firefox/all/ ) ?
Flags: needinfo?(tantrido)
(Reporter)

Comment 3

2 years ago
>how are you copying/pasting (keyboard, context menu, main menu, toolbar buttons, ... ?)
either do not work.

>Are there any errors in the browser console (ctrl-shift-j) when pasting fails?
No errors.

> Are you using a distro build of Firefox, and if so, can you reproduce on an official build ( https://www.mozilla.org/en-US/firefox/all/ ) ?
No, from openSUSE distro. Not reproducible with an official build.
Flags: needinfo?(tantrido)
(Reporter)

Comment 4

2 years ago
Changed branding package now from MozillaFirefox-branding-openSUSE to MozillaFirefox-branding-upstream, seems works now, thanks!

Comment 5

2 years ago
(In reply to Aleksey from comment #4)
> Changed branding package now from MozillaFirefox-branding-openSUSE to
> MozillaFirefox-branding-upstream, seems works now, thanks!

It might be worth filing a bug with opensuse (I'm not familiar with them, so can't really help, sorry!).

Marking this one WFM for now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

2 years ago
After some period of work (open some tabs, Youtube, etc) problem appeared again: can't copy-paste to an input.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Updated

2 years ago
Component: Keyboard Navigation → Layout: Form Controls
Product: Firefox → Core
(Reporter)

Comment 7

2 years ago
Still exist in Firefox 47, Linux Mint or openSUSE Linux.

Comment 8

2 years ago
(In reply to Aleksey from comment #7)
> Still exist in Firefox 47, Linux Mint or openSUSE Linux.

I take it this happens with an official build as well? Can you post the contents of about:support?

This really needs proper triaging. At this stage I have no idea what would cause this, but it's clear it doesn't happen to everyone all the time or it'd be failing automated tests and we'd have dozens of dupes of this report. It could very well still be a Firefox bug, but we need to narrow down when/how/why exactly it happens.
Component: Layout: Form Controls → Untriaged
Flags: needinfo?(tantrido)
Product: Core → Firefox
(Reporter)

Comment 9

2 years ago
Yes, reproducible with official build as well. Content attached.
(Reporter)

Comment 10

2 years ago
Created attachment 8772070 [details]
about:support
Flags: needinfo?(tantrido)

Comment 11

2 years ago
(In reply to Aleksey from comment #10)
> Created attachment 8772070 [details]
> about:support

My best guess is that it's related to one of your add-ons, but I wouldn't want to take any guesses which one. I'm guessing this doesn't reproduce in a new profile?
Flags: needinfo?(tantrido)
(Reporter)

Comment 12

2 years ago
Scrolling issues appears time to time, not reproducible in clean or my regular profile for now.
Flags: needinfo?(tantrido)

Comment 13

2 years ago
> Scrolling issues appears time to time, not reproducible in clean or my
> regular profile for now.

Closing this as Worksforme then. If you can still reproduce the issue on a clean profile, feel free to reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 14

2 years ago
This happens after session restore, also I can't load more often visited sites list (from URL bar) in this case. Think it is connected with Bug 1259133.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Reporter)

Comment 15

2 years ago
P.S. If I restart FF then - all works fine.

Comment 16

2 years ago
User Agent 	Mozilla/5.0 (X11; Linux x86_64; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID 	20160916101415

Hi, 
I tried to reproduce the issue on Firefox 49 but I could not. After session restore I can scroll the pages, can copy-paste text, and can load visited sites from URL bar. I tried on Ubuntu 15.04.
Do you still reproduce the issue on the last release (FF 49)?
Flags: needinfo?(tantrido)
(Reporter)

Comment 17

2 years ago
Not reproducible in FF 48 as well for me now. Will check 49 when update available in Linux Mint.

Comment 18

2 years ago
Thanks Aleksey. 
Please leave a comment after you check 49 too.

Updated

2 years ago
Component: Untriaged → Tabbed Browser

Comment 19

2 years ago
We're going to need a lot more info here to move forward, and it seems the reporter could no longer reproduce, so going to close as incomplete. We can reopen if there's enough information that points out there's a specific problem for Firefox to fix (rather than an add-on breaking things), and then move it to the right component when we actually know where/why things are breaking.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 20

2 years ago
Not reproducible in 49 for now.
(Reporter)

Updated

2 years ago
Flags: needinfo?(tantrido)
You need to log in before you can comment on or make changes to this bug.