Assertion failure: aTargetElement->GetCurrentDoc() (we should only be able to actively animate nodes that are in a document), at StyleAnimationValue.cpp:2596

RESOLVED DUPLICATE of bug 1239889

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 1239889
3 years ago
3 years ago

People

(Reporter: Tomcat, Unassigned)

Tracking

(Blocks: 1 bug, {assertion})

Trunk
assertion
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox47 affected)

Details

(URL)

(Reporter)

Description

3 years ago
found via bughunter and reproduced on http://www.express.co.uk/news/uk/638808/Tinder-siren-lures-man-drive-sexual-encounter-several-pints-uk with a windows 7 debug build based on todays m-c tip 

Assertion failure: aTargetElement->GetCurrentDoc() (we should only be able to actively animate nodes that are in a document), at c:/Users/mozilla/debug-builds/mozilla-central/layout/style/StyleAnimationValue.cpp:2596
#01: mozilla::BaseTimeDuration<mozilla::StickyTimeDurationValueCalculator>::FromTicks[xul +0x1d994d1]
#02: mozilla::dom::KeyframeEffectReadOnly::BuildAnimationPropertyList[xul +0x1d9182e]
#03: mozilla::dom::KeyframeEffectReadOnly::BuildAnimationPropertyList[xul +0x1d916bd]
#04: mozilla::dom::KeyframeEffectReadOnly::Constructor[xul +0x1d95251]
#05: mozilla::dom::Element::Animate (c:\users\mozilla\debug-builds\mozilla-central\dom\base\element.cpp:3342)
#06: mozilla::dom::GetParentObject<nsIDocument,1>::Get[xul +0x2e2f72e]
#07: mozilla::dom::GenericBindingMethod[xul +0x3076c0b]
#08: js::CallJSNative (c:\users\mozilla\debug-builds\mozilla-central\js\src\jscntxtinlines.h:235)
#09: js::Invoke (c:\users\mozilla\debug-builds\mozilla-central\js\src\vm\interpreter.cpp:475)
#10: Interpret (c:\users\mozilla\debug-builds\mozilla-central\js\src\vm\interpreter.cpp:2799)
#11: js::RunScript (c:\users\mozilla\debug-builds\mozilla-central\js\src\vm\interpreter.cpp:425)
#12: js::Invoke (c:\users\mozilla\debug-builds\mozilla-central\js\src\vm\interpreter.cpp:493)
#13: js::Invoke (c:\users\mozilla\debug-builds\mozilla-central\js\src\vm\interpreter.cpp:527)
#14: js::DirectProxyHandler::call (c:\users\mozilla\debug-builds\mozilla-central\js\src\proxy\directproxyhandler.cpp:77)
#15: js::CrossCompartmentWrapper::call (c:\users\mozilla\debug-builds\mozilla-central\js\src\proxy\crosscompartmentwrapper.cpp:289)
#16: js::Proxy::call (c:\users\mozilla\debug-builds\mozilla-central\js\src\proxy\proxy.cpp:391)
#17: js::proxy_Call (c:\users\mozilla\debug-builds\mozilla-central\js\src\proxy\proxy.cpp:683)
#18: js::CallJSNative (c:\users\mozilla\debug-builds\mozilla-central\js\src\jscntxtinlines.h:235)
#19: js::Invoke (c:\users\mozilla\debug-builds\mozilla-central\js\src\vm\interpreter.cpp:463)
#20: Interpret (c:\users\mozilla\debug-builds\mozilla-central\js\src\vm\interpreter.cpp:2799)
#21: js::RunScript (c:\users\mozilla\debug-builds\mozilla-central\js\src\vm\interpreter.cpp:425)
#22: js::Invoke (c:\users\mozilla\debug-builds\mozilla-central\js\src\vm\interpreter.cpp:493)
#23: js::Invoke (c:\users\mozilla\debug-builds\mozilla-central\js\src\vm\interpreter.cpp:527)
#24: JS::Call (c:\users\mozilla\debug-builds\mozilla-central\js\src\jsapi.cpp:2883)
#25: mozilla::dom::Function::Call[xul +0x2ee1e39]
#26: mozilla::dom::Function::Call<nsCOMPtr<nsISupports> > (c:\users\mozilla\debug-builds\mozilla-central\firefox-debug\dist\include\mozilla\dom\functionbinding.h:58)
#27: nsGlobalWindow::RunTimeoutHandler (c:\users\mozilla\debug-builds\mozilla-central\dom\base\nsglobalwindow.cpp:11861)
#28: nsGlobalWindow::RunTimeout (c:\users\mozilla\debug-builds\mozilla-central\dom\base\nsglobalwindow.cpp:12095)
#29: nsGlobalWindow::TimerCallback (c:\users\mozilla\debug-builds\mozilla-central\dom\base\nsglobalwindow.cpp:12342)
#30: nsTimerImpl::Fire[xul +0x5d9c56]
#31: nsTimerEvent::Run[xul +0x5c8bba]
#32: nsThread::ProcessNextEvent[xul +0x5c21c7]
#33: NS_ProcessNextEvent (c:\users\mozilla\debug-builds\mozilla-central\xpcom\glue\nsthreadutils.cpp:297)
#34: mozilla::ipc::MessagePump::Run[xul +0xbf5ce1]
#35: MessageLoop::RunInternal[xul +0xb7ca8d]
#36: MessageLoop::RunHandler[xul +0xb7ca02]
#37: MessageLoop::Run[xul +0xb7c60d]
#38: nsBaseAppShell::Run[xul +0x40ee480]
#39: nsAppShell::Run (c:\users\mozilla\debug-builds\mozilla-central\widget\windows\nsappshell.cpp:257)
#40: nsAppStartup::Run[xul +0x519e61f]
#41: XREMain::XRE_mainRun (c:\users\mozilla\debug-builds\mozilla-central\toolkit\xre\nsapprunner.cpp:4278)
#42: XREMain::XRE_main (c:\users\mozilla\debug-builds\mozilla-central\toolkit\xre\nsapprunner.cpp:4375)
#43: XRE_main (c:\users\mozilla\debug-builds\mozilla-central\toolkit\xre\nsapprunner.cpp:4477)
#44: do_main (c:\users\mozilla\debug-builds\mozilla-central\browser\app\nsbrowserapp.cpp:212)
#45: NS_internal_main (c:\users\mozilla\debug-builds\mozilla-central\browser\app\nsbrowserapp.cpp:352)
#46: wmain (c:\users\mozilla\debug-builds\mozilla-central\toolkit\xre\nswindowswmain.cpp:131)
#47: __tmainCRTStartup (f:\dd\vctools\crt\crtw32\startup\crt0.c:255)
#48: BaseThreadInitThunk[kernel32 +0x4ee6c]
#49: RtlInitializeExceptionChain[ntdll +0x63ab3]
#50: RtlInitializeExceptionChain[ntdll +0x63a86]

mozilla@win-7-battlestar ~/debug-builds/mozilla-central/firefox-debug/dist/bin
Flags: needinfo?(hiikezoe)
This crash is the same as bug 1239889.
Flags: needinfo?(hiikezoe)
Blocks: 1245000
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1239889
You need to log in before you can comment on or make changes to this bug.