Base-modularize homescreenWindowManager

RESOLVED WONTFIX

Status

defect
RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: apastor, Assigned: apastor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 2 obsolete attachments)

46 bytes, text/x-github-pull-request
lchang
: review+
Details | Review
20.86 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet
Details
46 bytes, text/x-github-pull-request
Details | Review
Assignee

Description

3 years ago
No description provided.
Assignee

Updated

3 years ago
Depends on: 1244682
Summary: Base\ → Base-modularize homescreenWindowManager
Assignee

Updated

3 years ago
Blocks: 1245045
Assignee

Updated

3 years ago
Assignee: nobody → apastor
Assignee

Comment 2

3 years ago
Integration tests are passing, but could you guys please run a smoke test round with this patch? Thanks!
Flags: needinfo?(mlien)
Keywords: qawanted
Assignee

Comment 3

3 years ago
Comment on attachment 8716250 [details] [review]
[gaia] albertopq:1244686-base-module-homewindow > mozilla-b2g:master

Now that the launchers are migrated, we can move the homescreen_window_manager to a base module too, and load both launchers as a SUB_MODULE.
Attachment #8716250 - Flags: review?(lchang)
Comment on attachment 8716250 [details] [review]
[gaia] albertopq:1244686-base-module-homewindow > mozilla-b2g:master

The patch looks good. I noticed that you kept the "publish" method as-is in order to fire events with different prefix, did you?
Attachment #8716250 - Flags: review?(lchang) → review+
Assignee

Comment 5

3 years ago
That's correct. The phone system don't publish events with different prefix in that file anymore, so we can investigate that in a different bug, in order to use the baseModule publish method. Thanks for the review! Let's wait for the smoke tests results. Thanks again!

Comment 6

3 years ago
Posted file Smoke_Test_For_Bug 1244686.xlsx (obsolete) —
We run a test for this patch,please refer to the attachment.
We only found some existing issues and didn't find any regression issue.

Thanks.

Comment 7

3 years ago
Sorry, update the attachment.

Updated

3 years ago
Flags: needinfo?(mlien)
Keywords: qawanted

Comment 8

3 years ago
Attachment #8722810 - Attachment is obsolete: true
Attachment #8722812 - Attachment is obsolete: true
Assignee

Comment 9

3 years ago
master: https://github.com/mozilla-b2g/gaia/commit/70fef2d804057c85ab3b98ef22a179e5c4bc851d
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
reverted: https://github.com/mozilla-b2g/gaia/commit/45c7a3a5c3a7a32d0216eaa4363d6a3f5b2d7e97


Since the system merging plan has been suspended, we might need to revert some changes in order not to interfere with the transition plan and TV 2.6.
Resolution: FIXED → WONTFIX
You need to log in before you can comment on or make changes to this bug.