Crash if I apply another Windows XP color scheme while the browser is open

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
critical
RESOLVED WORKSFORME
16 years ago
13 years ago

People

(Reporter: Deryk Lister, Assigned: asa)

Tracking

({crash})

Trunk
x86
Windows XP
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:0.9.8) Gecko/20020204
BuildID:    2002020406

If you are using Windows XP's new visual 'style' and change the colour scheme
under 'display properties' in the control panel (eg. from blue to silver or
olive green), Mozilla crashes.

Currently using the "classic" theme in Mozilla.
I haven't tested this on another PC yet, or with the "modern" theme

Reproducible: Always
Steps to Reproduce:
1. Load up Mozilla in Windows XP
2. Go to Control Panel - Appearance and Themes - Display - Appearance
3. Change the colour scheme and apply the changes

Actual Results:  Standard Windows dialog box "mozilla.exe has encountered a
problem and needs to shut down.  We apologise for the inconvenience"

Marked 'critical' because it is a crash problem, but obviously it's more of a
niggle than anything else.
(Reporter)

Comment 1

16 years ago
Unfortunately I just tried this on another PC and failed to reproduce the bug
(applying the new scheme didn't crash the browser), making this more difficult
to pin down.

On this system, I can reproduce the problem on both the 'classic' and 'modern'
skins.
Reporter:
Have you installed Mozilla over an older build ?
Can you try a new profile (run "mozilla -profilemanager" and create a second
test profile)

If you still crash : Use a talkback enabled build and add the talkback ID# of
the crash to this bug.

Thanks
Keywords: crash
(Reporter)

Comment 3

16 years ago
A-ha.  I did indeed install over an old build, and creating another test profile
cured the problem.

Apologies for the confusion... will remember to install afresh next time.

Comment 4

16 years ago
Closing case. Works with current build
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
"fixed" is wrong...
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
-> wfm
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.