Closed Bug 1244720 Opened 4 years ago Closed 4 years ago

Add last missing jobs, fix any wrong settings and enable more green jobs

Categories

(Testing :: General, defect)

defect
Not set

Tracking

(firefox47 fixed)

RESOLVED FIXED
mozilla47
Tracking Status
firefox47 --- fixed

People

(Reporter: armenzg, Assigned: armenzg)

References

Details

Attachments

(8 files, 1 obsolete file)

No description provided.
Notes from Joel. Time to verify and fix!
````````````````````````````````````````
do we have Mn for taskcluster?  also R-e10s(J) ?

we run jetpack on buildbot, and not on tc!

missing in TC:
Mn
wpt-e10s(wr-e10s)
m(oth)

and we are running tc-m-e10s(*) without the --e10s flag!  I was looking into the dt jobs and realized that the plain, bc, and dt are all opt.

wpt(3) is failing in tc, but passing great in bb
wpt(4) is missing in both tc and bb
wpt-e10s(wr-e10s) is missing in tc
wpt-e10s(3 4) are missing in both tc bb (well 3 is failing bad and 4 is missing)

we are also running m-e10s(dt*) in tc, but I don't see them in the buildbot jobs on your try push...moar coverage :)
We don't run jetpack on debug builds

Added (in my next patch):
* Mn
* wr-e10s
* m-oth

Wrt to e10s jobs not using --e10s is very unfortunate. Even though --e10s is specified in the task definition!
I will investigate.
What do you mean by "opt"?

Wrt to m-e10s, that is fine. They had been forgotten for Buildbot. See bug 1242986.
I have jetpack definitions from buildbot on your try push:
https://treeherder.mozilla.org/#/jobs?repo=try&author=armenzg@mozilla.com&filter-searchStr=jetpack&exclusion_profile=false

We should turn off the jetpack scheduling or add it to taskcluster.  No point in turning it off accidentally a few weeks from now.


I mis-spoke on opt, I meant non-e10s, I usually refer to talos jobs as opt or e10s.  Looking forward to how these new jobs work out.
Wrt to --e10s:
https://public-artifacts.taskcluster.net/QPzXhw2rQvmYeVpFStRq8w/0/public/graph.json

wpt, reftests and crashtest uses it.

The problem is that one the same definition we have 'payload' a second time (woohoo!):
https://dxr.mozilla.org/mozilla-central/source/testing/taskcluster/tasks/tests/fx_linux64_mochitest_plain_e10s.yml#14
Comment on attachment 8714375 [details] [diff] [review]
fix mochitest e10s jobs + add jetpack definition

Review of attachment 8714375 [details] [diff] [review]:
-----------------------------------------------------------------

good find on the double payload definitions!  yay for in-tree configs to shoot you in the foot :)
Attachment #8714375 - Flags: review?(jmaher) → review+
Attachment #8714393 - Flags: review?(jmaher)
Comment on attachment 8714393 [details] [diff] [review]
Devtools are running without --chunk-by-runtime

Review of attachment 8714393 [details] [diff] [review]:
-----------------------------------------------------------------

nice!
Attachment #8714393 - Flags: review?(jmaher) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/6554c3c4f0ea0c27f58b356938ae67764cdb44c6
Bug 1244720 - TaskCluster Linux64 mochitest devtools are running without --chunk-by-runtime. DONTBUILD. r=jmaher
This has to go with attachement 8714375 (since mochitest e10s is running side by side on production).
Attachment #8714473 - Flags: review?(jmaher)
Comment on attachment 8714473 [details] [diff] [review]
Disable mochitest e10s, increase Marionette and m-other runtime and fix jetpack

Review of attachment 8714473 [details] [diff] [review]:
-----------------------------------------------------------------

lots of little changes, thanks for making this smooth
Attachment #8714473 - Flags: review?(jmaher) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/1c6457541936f6df1ea797bfd545b906c738fcdf
Bug 1244720 - Modifications to tier 2 TaskCluster jobs. DONTBUILD. r=jmaher
Blocks: 1244936
https://hg.mozilla.org/mozilla-central/rev/6554c3c4f0ea
https://hg.mozilla.org/mozilla-central/rev/1c6457541936
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla47
Comment on attachment 8714772 [details] [diff] [review]
disable_bc.diff

Review of attachment 8714772 [details] [diff] [review]:
-----------------------------------------------------------------

sold
Attachment #8714772 - Flags: review?(jmaher) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/c3de1fe6ce6c1dcc5bbbd40c65ded15fc5a8c17f
Bug 1244720 - Disable TaskCluster tier2 e10s mochitest-browser-chrome. DONTBUILD r=jmaher
Status: RESOLVED → REOPENED
Keywords: leave-open
Resolution: FIXED → ---
Attachment #8715847 - Flags: review?(jmaher)
Comment on attachment 8715847 [details] [diff] [review]
Allow running Wr e10s

Review of attachment 8715847 [details] [diff] [review]:
-----------------------------------------------------------------

good find!
Attachment #8715847 - Flags: review?(jmaher) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/a7f2b93dd5645b22e82e7fa5dfef6a926e46ea83
Bug 1244720 - Allow scheduling on try Wr-e10s jobs for TaskCluster Linux64 debug builds. tier-2. DONTBUILD. r=jmaher
Because they're borderlining 60 minutes.
Attachment #8717096 - Flags: review?(dustin)
Attachment #8717096 - Flags: review?(dustin) → review+
Since dt6 and dt8 are bordering 60 minutes.
Attachment #8717155 - Flags: review?(dustin)
Attachment #8717155 - Flags: review?(dustin) → review+
Comment on attachment 8717155 [details] [diff] [review]
Bump devtools timeout from 60 to 90 minutes

It seems this landed with https://reviewboard.mozilla.org/r/33831/diff/2#index_header

I was based on m-c.
I decided we don't want to go from 10 to 8 chunks.
Attachment #8717155 - Attachment is obsolete: true
https://hg.mozilla.org/integration/mozilla-inbound/rev/1e5acf7ffffc538147ec6c56663f6ffce32f2a77
Bug 1244720 - TaskCluster tier2 jobs: bump wpt reftests from 60 to 90 minutes time out. DONTBUILD. r=dustin
https://treeherder.mozilla.org/#/jobs?repo=try&revision=88d1caed025e&group_state=expanded&selectedJob=16559429

Wr has recently become very intermittent.
I've a patch to fix it.
Attachment #8718044 - Flags: review?(dustin)
No longer blocks: 1244936
Attachment #8718044 - Flags: review?(dustin) → review+
We can wait to land once we have the last two issues greened up.
Attachment #8720288 - Flags: review?(jmaher)
Comment on attachment 8720288 [details] [diff] [review]
Enable mochitest-plain-e10s and mochitest-browser-chrome-e10s

Review of attachment 8720288 [details] [diff] [review]:
-----------------------------------------------------------------

yes, once we are green- we might need to disable tests at the same time.
Attachment #8720288 - Flags: review?(jmaher) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/d8f9f159cee2b704177973576215c4f7d83d0a90
Bug 1244720 - Enable mochitest plain and mochitest browser-chrome for e10s. tier-2 jobs. r=jmaher
Status: REOPENED → RESOLVED
Closed: 4 years ago4 years ago
Resolution: --- → FIXED
Removing leave-open keyword from resolved bugs, per :sylvestre.
Keywords: leave-open
You need to log in before you can comment on or make changes to this bug.