Detect hand written copy constructors and assignment operators that can be default

RESOLVED DUPLICATE of bug 1229476

Status

RESOLVED DUPLICATE of bug 1229476
3 years ago
9 months ago

People

(Reporter: jrmuizel, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Comment 1

3 years ago
Are these acceptable definitions:
Copy or assignment contains only assignment statements, for all members (followed by `return *this` for assignment)? If there's any more complex logic we'd consider the constructor/assignment operator necessary?

I'm not sure if it'd cover every instance of a trivial constructor which we could eliminate, but there's a chance it's good enough to catch a bunch.
Flags: needinfo?(jmuizelaar)
(Reporter)

Comment 2

3 years ago
Yeah, that sound reasonable.
Flags: needinfo?(jmuizelaar)
(Reporter)

Updated

3 years ago
Summary: Detect hand written copy constructors and assignment operators. → Detect hand written copy constructors and assignment operators that can be default
Both of these bugs filed by jrmuizel :)
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1229476

Updated

9 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.